summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-17 12:06:26 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-17 12:06:26 +0000
commitede312f877c592aaadf33400bfbc73dc869f1eb8 (patch)
tree839b588a91dad0d7878b3a0d53c879f0b9cbb097 /media-sound/gnome-alsamixer
parentCorrected apache2 handling and shell error. (Manifest recommit) (diff)
downloadgentoo-2-ede312f877c592aaadf33400bfbc73dc869f1eb8.tar.gz
gentoo-2-ede312f877c592aaadf33400bfbc73dc869f1eb8.tar.bz2
gentoo-2-ede312f877c592aaadf33400bfbc73dc869f1eb8.zip
Version bump closes bug #35870.
Diffstat (limited to 'media-sound/gnome-alsamixer')
-rw-r--r--media-sound/gnome-alsamixer/ChangeLog9
-rw-r--r--media-sound/gnome-alsamixer/Manifest5
-rw-r--r--media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.61
-rw-r--r--media-sound/gnome-alsamixer/files/gnome-alsamixer.desktop11
-rw-r--r--media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild15
-rw-r--r--media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild27
-rw-r--r--media-sound/gnome-alsamixer/metadata.xml5
7 files changed, 61 insertions, 12 deletions
diff --git a/media-sound/gnome-alsamixer/ChangeLog b/media-sound/gnome-alsamixer/ChangeLog
index 7fb5b08eb877..dbf2b661aff4 100644
--- a/media-sound/gnome-alsamixer/ChangeLog
+++ b/media-sound/gnome-alsamixer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/gnome-alsamixer
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/ChangeLog,v 1.2 2004/01/17 03:27:33 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/ChangeLog,v 1.3 2004/02/17 12:06:26 eradicator Exp $
+
+*gnome-alsamixer-0.9.6 (17 Feb 2004)
+
+ 17 Feb 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ gnome-alsamixer-0.9.3.ebuild, gnome-alsamixer-0.9.6.ebuild, metadata.xml,
+ files/gnome-alsamixer.desktop:
+ Version bump closes bug #35870.
17 Jan 2004; Bartosch Pixa <darkspecter@gentoo.org>
gnome-alsamixer-0.9.3.ebuild:
diff --git a/media-sound/gnome-alsamixer/Manifest b/media-sound/gnome-alsamixer/Manifest
index dd940eef48e9..7d916b6992cd 100644
--- a/media-sound/gnome-alsamixer/Manifest
+++ b/media-sound/gnome-alsamixer/Manifest
@@ -1,3 +1,6 @@
-MD5 be392c7e72250985346758fb56d44154 ChangeLog 639
+MD5 fa9d6dd3272fc72e95b61c06ca2bc504 gnome-alsamixer-0.9.6.ebuild 966
MD5 fa9d6dd3272fc72e95b61c06ca2bc504 gnome-alsamixer-0.9.3.ebuild 966
+MD5 be392c7e72250985346758fb56d44154 ChangeLog 639
+MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 cda3ce4e4127b307f956a8a48dfa44db files/digest-gnome-alsamixer-0.9.3 72
+MD5 8ee992b81ac5ed728c89cea5addf5dff files/digest-gnome-alsamixer-0.9.6 72
diff --git a/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.6 b/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.6
new file mode 100644
index 000000000000..ed95d98c4809
--- /dev/null
+++ b/media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.6
@@ -0,0 +1 @@
+MD5 387623cfeb079d78325eed2d6bc94251 gnome-alsamixer-0.9.6.tar.gz 93557
diff --git a/media-sound/gnome-alsamixer/files/gnome-alsamixer.desktop b/media-sound/gnome-alsamixer/files/gnome-alsamixer.desktop
new file mode 100644
index 000000000000..73082bfb8d42
--- /dev/null
+++ b/media-sound/gnome-alsamixer/files/gnome-alsamixer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=ALSA Volume Control
+Comment=Adjust the volume level
+Exec=gnome-alsamixer
+Icon=gnome-alsamixer/gnome-alsamixer-icon.png
+Info=Gnome ALSA Mixer
+Terminal=0
+Type=Application
+Categories=Application;AudioVideo;X-Red-Hat-Base;
+Encoding=UTF-8
+X-Desktop-File-Install-Version=0.3
diff --git a/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild
index 9c4b7d96befe..17e0d0f2afd3 100644
--- a/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild
+++ b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild,v 1.5 2004/01/17 03:27:33 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.3.ebuild,v 1.6 2004/02/17 12:06:26 eradicator Exp $
IUSE=""
DESCRIPTION="Gnome 2 based ALSA Mixer"
@@ -15,21 +15,16 @@ RDEPEND=">=media-libs/alsa-lib-0.9.0_rc1
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/desktop-file-utils"
-S=${WORKDIR}/${P}
-
-src_compile() {
- econf || die "configure failed"
- emake || die
-}
src_install() {
-
# hack to prevent ugly filenames in /usr/share/applications
- cd ${S}; mv ${PN}.desktop ${PN}.desktop.gentoo
+ mv ${PN}.desktop ${PN}.desktop.gentoo
- einstall || die
+ make DESTDIR=${D} || die
# manuall install menu entry
insinto /usr/share/applications
newins ${PN}.desktop.gentoo ${PN}.desktop
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL
}
diff --git a/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild
new file mode 100644
index 000000000000..d955f8c5a30e
--- /dev/null
+++ b/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild,v 1.1 2004/02/17 12:06:26 eradicator Exp $
+
+IUSE=""
+DESCRIPTION="Gnome 2 based ALSA Mixer"
+HOMEPAGE="http://www.paw.co.za/projects/gnome-alsamixer"
+SRC_URI="ftp://ftp.paw.co.za/pub/PAW/sources/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+RDEPEND=">=media-libs/alsa-lib-0.9.0_rc1
+ >=x11-libs/gtk+-2.0.6
+ >=gnome-base/libgnomeui-2.0.5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/desktop-file-utils"
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # manuall install menu entry
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL
+}
diff --git a/media-sound/gnome-alsamixer/metadata.xml b/media-sound/gnome-alsamixer/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/gnome-alsamixer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>