summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 14:43:47 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 14:43:47 +0000
commite73360b65f64584277dde6718834f289eb7ebc87 (patch)
treeb96383c2ef711bd70bdf0aa99ec514982b62e96a /media-sound/gnomoradio
parentAdd a warning about the need for logging out and back in. (diff)
downloadgentoo-2-e73360b65f64584277dde6718834f289eb7ebc87.tar.gz
gentoo-2-e73360b65f64584277dde6718834f289eb7ebc87.tar.bz2
gentoo-2-e73360b65f64584277dde6718834f289eb7ebc87.zip
Let it compile against glib-2.32
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/gnomoradio')
-rw-r--r--media-sound/gnomoradio/ChangeLog7
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch53
-rw-r--r--media-sound/gnomoradio/gnomoradio-0.15.1.ebuild12
3 files changed, 62 insertions, 10 deletions
diff --git a/media-sound/gnomoradio/ChangeLog b/media-sound/gnomoradio/ChangeLog
index 4a3dcdd84c87..60ff057d82e5 100644
--- a/media-sound/gnomoradio/ChangeLog
+++ b/media-sound/gnomoradio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gnomoradio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/ChangeLog,v 1.23 2012/05/05 09:02:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/ChangeLog,v 1.24 2012/07/21 14:43:47 pacho Exp $
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gnomoradio-0.15.1-glib-single-include.patch, gnomoradio-0.15.1.ebuild:
+ Let it compile against glib-2.32
05 May 2012; Michał Górny <mgorny@gentoo.org> gnomoradio-0.15.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -89,4 +93,3 @@
+gnomoradio-0.11.2.ebuild:
Initial Import. Closes #37527.
Thanks to mattgerg@users.sourceforge.net for the initial ebuild.
-
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch
new file mode 100644
index 000000000000..168872e57cae
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-glib-single-include.patch
@@ -0,0 +1,53 @@
+Index: gnomoradio-0.15.1/roboradio/mp3/common.c
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/common.c
++++ gnomoradio-0.15.1/roboradio/mp3/common.c
+@@ -19,7 +19,7 @@
+ #include "id3.h"
+ #include "id3_header.h"
+
+-#include <glib/gmem.h>
++#include <glib.h>
+
+ /* max = 1728 */
+ #define MAXFRAMESIZE 1792
+Index: gnomoradio-0.15.1/roboradio/mp3/esd-audio.c
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/esd-audio.c
++++ gnomoradio-0.15.1/roboradio/mp3/esd-audio.c
+@@ -2,8 +2,7 @@
+ #include <config.h>
+ #include "esd-audio.h"
+
+-#include <glib/gmem.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <pthread.h>
+ #include <stdlib.h>
+ #include <string.h>
+Index: gnomoradio-0.15.1/roboradio/mp3/esd-audio.h
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/esd-audio.h
++++ gnomoradio-0.15.1/roboradio/mp3/esd-audio.h
+@@ -1,7 +1,7 @@
+ #ifndef ESD_AUDIO_H
+ #define ESD_AUDIO_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ #define N_(string) string
+
+Index: gnomoradio-0.15.1/roboradio/mp3/id3.h
+===================================================================
+--- gnomoradio-0.15.1.orig/roboradio/mp3/id3.h
++++ gnomoradio-0.15.1/roboradio/mp3/id3.h
+@@ -28,7 +28,7 @@
+ #ifndef ID3_H
+ #define ID3_H
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ /*
+ * Option flags to id3_open_*().
diff --git a/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild b/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
index 26a507bf315b..173611191499 100644
--- a/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
+++ b/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild,v 1.13 2012/05/05 09:02:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild,v 1.14 2012/07/21 14:43:47 pacho Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="Finds, fetches, shares, and plays freely licensed music."
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc42.patch \
"${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-lm.patch
+ "${FILESDIR}"/${P}-lm.patch \
+ "${FILESDIR}"/${P}-glib-single-include.patch
eautoreconf
}
@@ -36,8 +37,3 @@ src_configure() {
--disable-dependency-tracking \
$(use_enable vorbis)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}