summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-11-24 00:13:34 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-11-24 00:13:34 +0000
commit589842da96d31768707a0ef5e51fa870f0a679e1 (patch)
tree25dd2fb66d3f300f175d8ced323b11c80dda8a57 /media-sound/lame
parentadd quotes around all filenames/dirnames so that names with spaces in them work (diff)
downloadgentoo-2-589842da96d31768707a0ef5e51fa870f0a679e1.tar.gz
gentoo-2-589842da96d31768707a0ef5e51fa870f0a679e1.tar.bz2
gentoo-2-589842da96d31768707a0ef5e51fa870f0a679e1.zip
the new lame release, last in the current stable development, now it goes unstable soon. I removed vorbis since its gone from the lame tree (at least according to the ChangeLog, and the build fails with it enabled) I also did some hacking on getting the version/source to match (they packaged it as 3.93 and marked it 3.93.0 as a tarball. bah. )
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog11
-rw-r--r--media-sound/lame/files/digest-lame-3.93.01
-rw-r--r--media-sound/lame/lame-3.93.0.ebuild63
3 files changed, 74 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 8e2f2dad4728..f7ca3ee45575 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.7 2002/09/29 14:52:52 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.8 2002/11/24 00:13:34 spider Exp $
+
+
+*lame-3.93.0 (23 Nov 2002)
+
+ 23 Nov 2002; Spider <spider@gentoo.org> lame-3.93.0.ebuild :
+ new versioning scheme, unfortunately not followed inside the tarball so I
+ had to hack some there. The vorbis support was cut out from this release
+ (at least according to the changelog) so I removed the IUSE and USE flags
+ accordingly.
*lame-3.92 (23 Apr 2002)
29 Sep 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/media-sound/lame/files/digest-lame-3.93.0 b/media-sound/lame/files/digest-lame-3.93.0
new file mode 100644
index 000000000000..1184ed7afd05
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.93.0
@@ -0,0 +1 @@
+MD5 2c054c7eec1f966499d0945642bd8cba lame-3.93.0.tar.gz 1036360
diff --git a/media-sound/lame/lame-3.93.0.ebuild b/media-sound/lame/lame-3.93.0.ebuild
new file mode 100644
index 000000000000..98b8dbc0529c
--- /dev/null
+++ b/media-sound/lame/lame-3.93.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.0.ebuild,v 1.1 2002/11/24 00:13:34 spider Exp $
+
+IUSE="gtk"
+
+inherit libtool
+MY_PV=`echo ${PV}|cut -d . -f -2`
+S=${WORKDIR}/lame-${MY_PV}
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+HOMEPAGE="http://www.mp3dev.org/mp3/"
+
+DEPEND="virtual/glibc
+ x86? ( dev-lang/nasm )
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+# this release completely removed oggvorbis support as it was too outdated.
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ if [ "`use gtk`" ] ; then
+ myconf="${myconf} --enable-mp3x"
+ fi
+ if [ "${DEBUG}" ] ; then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-nasm \
+ --enable-mp3rtp \
+ --enable-extopt=full \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ pkghtmldir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ dohtml -r ./
+}
+