summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-05 17:35:45 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-05 17:35:45 +0000
commit4a805d0af831974a4fe8815100023a27e820ec5f (patch)
tree21dbfd67d5e54b82ecc46b1378f17ddbed2dd571 /media-sound/lastfmplayer
parentRevision bump to support new Java system (diff)
downloadgentoo-2-4a805d0af831974a4fe8815100023a27e820ec5f.tar.gz
gentoo-2-4a805d0af831974a4fe8815100023a27e820ec5f.tar.bz2
gentoo-2-4a805d0af831974a4fe8815100023a27e820ec5f.zip
Add proper debugging support thanks to Santiago M. Mola Velasco <cooldwind@gmail.com> in bug 142875
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'media-sound/lastfmplayer')
-rw-r--r--media-sound/lastfmplayer/ChangeLog7
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild26
2 files changed, 27 insertions, 6 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index e72c1aff8b64..725a29d165d7 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.6 2006/07/28 22:36:26 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.7 2006/08/05 17:35:45 genstef Exp $
+
+ 05 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
+ lastfmplayer-1.0.0.1_p2113.ebuild:
+ Add proper debugging support thanks to Santiago M. Mola Velasco
+ <cooldwind@gmail.com> in bug 142875
28 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+files/lastfmplayer-amd64.patch, lastfmplayer-1.0.0.1_p2113.ebuild:
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild
index bd65210f5485..1f03f6777169 100644
--- a/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild
+++ b/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild,v 1.2 2006/07/28 22:36:26 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.0.0.1_p2113.ebuild,v 1.3 2006/08/05 17:35:45 genstef Exp $
inherit eutils subversion versionator
@@ -13,7 +13,7 @@ ESVN_OPTIONS="--revision ${PV#*_p}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
+IUSE="debug"
DEPEND="=x11-libs/qt-4*"
RDEPEND="${DEPEND}"
@@ -29,10 +29,19 @@ pkg_setup() {
die "no gif or png support in qt"
fi
+
+ if use debug && ! built_with_use x11-libs/qt debug ; then
+ eerror "In order to use debug, you need to compile Qt 4"
+ eerror "with debug USE flag."
+ fi
}
src_compile() {
- qmake || die "qmake failed"
+ if use debug ; then
+ qmake CONFIG+=debug || die "qmake failed"
+ else
+ qmake CONFIG-=debug QMAKE_TARGET=LastFM || die "qmake failed"
+ fi
emake qmake_all || die "emake qmake_all failed"
epatch ${FILESDIR}/lastfmplayer-amd64.patch
emake || die "emake failed"
@@ -47,9 +56,16 @@ src_install() {
local destination="/opt/lastfm"
cd bin
+ #Bin name
+ if ! use debug ; then
+ MY_B=LastFM
+ else
+ MY_B=LastFM_debug
+ fi
+
# Install the player
exeinto ${destination}
- doexe LastFM
+ doexe ${MY_B}
# Install libraries and symlinks
v=( $(get_version_components ) )
@@ -70,7 +86,7 @@ src_install() {
keepdir ${destination}/cache
# Icon, menu, protcol
- make_wrapper lastfm ./LastFM ${destination} ${destination}
+ make_wrapper lastfm ./${MY_B} ${destination} ${destination}
newicon data/icon.png lastfm.png
make_desktop_entry lastfm "Last.fm Player" lastfm.png