summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-09-16 18:27:45 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-09-16 18:27:45 +0000
commit43a50b9d2512e9710b6e6f1b51afb79717f04035 (patch)
tree364ed289969d7d03cc230e0d887198bc331cecb3 /media-sound/linuxsampler
parentMore strict dependencies, taking those from the respective xorg-server versio... (diff)
downloadgentoo-2-43a50b9d2512e9710b6e6f1b51afb79717f04035.tar.gz
gentoo-2-43a50b9d2512e9710b6e6f1b51afb79717f04035.tar.bz2
gentoo-2-43a50b9d2512e9710b6e6f1b51afb79717f04035.zip
Fix build with GCC 4.7 (bug #414033), port to EAPI 4, and do the static-libs
dance. (Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/linuxsampler')
-rw-r--r--media-sound/linuxsampler/ChangeLog9
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch13
-rw-r--r--media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild54
3 files changed, 75 insertions, 1 deletions
diff --git a/media-sound/linuxsampler/ChangeLog b/media-sound/linuxsampler/ChangeLog
index 05cdf048e6db..c3952ed791b4 100644
--- a/media-sound/linuxsampler/ChangeLog
+++ b/media-sound/linuxsampler/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/linuxsampler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.15 2012/05/05 08:33:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.16 2012/09/16 18:27:45 dirtyepic Exp $
+
+*linuxsampler-1.0.0-r1 (17 Sep 2012)
+
+ 17 Sep 2012; Ryan Hill <dirtyepic@gentoo.org> +linuxsampler-1.0.0-r1.ebuild,
+ +files/linuxsampler-1.0.0-gcc47.patch:
+ Fix build with GCC 4.7 (bug #414033), port to EAPI 4, and do the static-libs
+ dance.
05 May 2012; Michał Górny <mgorny@gentoo.org> linuxsampler-0.5.1.ebuild,
linuxsampler-1.0.0.ebuild:
diff --git a/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch b/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch
new file mode 100644
index 000000000000..e46fb243b6ce
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-1.0.0-gcc47.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/414033
+
+--- a/src/common/Pool.h
++++ b/src/common/Pool.h
+@@ -393,7 +393,7 @@ class RTList : public RTListBase<T> {
+ inline Iterator allocAppend() {
+ if (pPool->poolIsEmpty()) return RTListBase<T>::begin();
+ Iterator element = pPool->alloc();
+- append(element);
++ this->append(element);
+ #if CONFIG_DEVMODE
+ element.list = this;
+ #endif // CONFIG_DEVMODE
diff --git a/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild b/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d2f48e6bb49f
--- /dev/null
+++ b/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-1.0.0-r1.ebuild,v 1.1 2012/09/16 18:27:45 dirtyepic Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="LinuxSampler is a software audio sampler engine with professional grade features."
+HOMEPAGE="http://www.linuxsampler.org/"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack sqlite static-libs"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3.3 )
+ >=media-libs/libgig-3.3.0
+ media-libs/alsa-lib
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ econf --enable-alsa-driver \
+ --disable-arts-driver \
+ $(use_enable jack jack-driver) \
+ $(use_enable sqlite instruments-db) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ emake docs
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+
+ prune_libtool_files
+}