summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-10-22 11:40:23 +0000
committerJon Hood <squinky86@gentoo.org>2004-10-22 11:40:23 +0000
commitdad675eac57c8b30c75107557420a19b053c6d00 (patch)
treeb0ce3a57a8b887716804d0ac19859ba727dee3aa /media-sound/mhwaveedit
parentinitial commit, theora plug-in (Manifest recommit) (diff)
downloadgentoo-2-dad675eac57c8b30c75107557420a19b053c6d00.tar.gz
gentoo-2-dad675eac57c8b30c75107557420a19b053c6d00.tar.bz2
gentoo-2-dad675eac57c8b30c75107557420a19b053c6d00.zip
gcc-3.4 fixin'
Diffstat (limited to 'media-sound/mhwaveedit')
-rw-r--r--media-sound/mhwaveedit/ChangeLog6
-rw-r--r--media-sound/mhwaveedit/files/1.2.3-gcc34.patch11
-rw-r--r--media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/mhwaveedit/ChangeLog b/media-sound/mhwaveedit/ChangeLog
index 73dd18e885a2..8a88f8a1d0e2 100644
--- a/media-sound/mhwaveedit/ChangeLog
+++ b/media-sound/mhwaveedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mhwaveedit
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/ChangeLog,v 1.4 2004/06/25 00:10:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/ChangeLog,v 1.5 2004/10/22 11:40:23 squinky86 Exp $
+
+ 22 Oct 2004; Jon Hood <squinky86@gentoo.org> +files/1.2.3-gcc34.patch,
+ mhwaveedit-1.2.3.ebuild:
+ Added gcc-3.4 fix, #68158.
03 Feb 2004; Jeremy Huddleston <eradicator@gentoo.org> metadata.xml,
mhwaveedit-1.2.1.ebuild, mhwaveedit-1.2.3.ebuild:
diff --git a/media-sound/mhwaveedit/files/1.2.3-gcc34.patch b/media-sound/mhwaveedit/files/1.2.3-gcc34.patch
new file mode 100644
index 000000000000..2bb9ddf3a033
--- /dev/null
+++ b/media-sound/mhwaveedit/files/1.2.3-gcc34.patch
@@ -0,0 +1,11 @@
+diff -Naur mhwaveedit-1.2.3.vanilla/src/filetypes.c mhwaveedit-1.2.3/src/filetypes.c
+--- mhwaveedit-1.2.3.vanilla/src/filetypes.c 2003-05-27 13:36:05.000000000 -0500
++++ mhwaveedit-1.2.3/src/filetypes.c 2004-10-21 21:33:10.755276896 -0500
+@@ -613,6 +613,7 @@
+ info->samplerate,info->channels); */
+ if (sf_format_check(info)) return FALSE;
+ outer:
++ {}
+ }
+ /* Try the left out suggestions finally... */
+ i = fmt->samplesize;
diff --git a/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild b/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild
index b2334dc0064a..79b63ce75600 100644
--- a/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild
+++ b/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild,v 1.4 2004/06/25 00:10:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mhwaveedit/mhwaveedit-1.2.3.ebuild,v 1.5 2004/10/22 11:40:23 squinky86 Exp $
+
+inherit eutils
IUSE="gtk2 oss sdl"
@@ -18,6 +20,12 @@ DEPEND="gtk2? ( >=x11-libs/gtk+-2.0.0 )
>=media-libs/libsndfile-1.0.1
>=media-libs/portaudio-18"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc34.patch
+}
+
src_compile() {
econf `use_enable gtk2` `use_with oss` `use_with sdl` || die
emake || die