summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-06-22 05:06:37 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-06-22 05:06:37 +0000
commitd3f9a3b1c1bbfd6c326cf2760308f12ed09b77ee (patch)
tree0d54dd1b99f48eb700f50b0833a81b939b62e6fe /media-sound/mp3kult/mp3kult-0.7-r1.ebuild
parentblah (diff)
downloadgentoo-2-d3f9a3b1c1bbfd6c326cf2760308f12ed09b77ee.tar.gz
gentoo-2-d3f9a3b1c1bbfd6c326cf2760308f12ed09b77ee.tar.bz2
gentoo-2-d3f9a3b1c1bbfd6c326cf2760308f12ed09b77ee.zip
Fix for mysql ssl linking issues.
Diffstat (limited to 'media-sound/mp3kult/mp3kult-0.7-r1.ebuild')
-rw-r--r--media-sound/mp3kult/mp3kult-0.7-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-sound/mp3kult/mp3kult-0.7-r1.ebuild b/media-sound/mp3kult/mp3kult-0.7-r1.ebuild
index cb77b8650e0a..814583aa7d3d 100644
--- a/media-sound/mp3kult/mp3kult-0.7-r1.ebuild
+++ b/media-sound/mp3kult/mp3kult-0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3kult/mp3kult-0.7-r1.ebuild,v 1.1 2003/06/21 11:29:17 jje Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3kult/mp3kult-0.7-r1.ebuild,v 1.2 2003/06/22 05:06:25 jje Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Mp3Kult organizes your mp3/ogg collection in a Mysql database."
@@ -20,6 +20,9 @@ RDEPEND="${DEPEND}"
src_compile() {
export CXXFLAGS="${CXXFLAGS} -DUSE_OLD_FUNCTIONS=1"
+ # For whatever reason defining USE_OLD_FUNCTIONS causes
+ # link errors for ssl; the next line fixes it.
+ export LDFLAGS="-lssl"
econf || die
emake || die
}