summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-11 09:55:18 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-11 09:55:18 +0000
commit7f0ecf4d3ab64a8aa25585fb21aaf64f81aad286 (patch)
tree7a289628ef12449ee118b43b1545be8f18309996 /media-sound/mpd
parentFix #403133 by Alexander Holler, thanks to Greg for testing. Fix #425082 than... (diff)
downloadgentoo-2-7f0ecf4d3ab64a8aa25585fb21aaf64f81aad286.tar.gz
gentoo-2-7f0ecf4d3ab64a8aa25585fb21aaf64f81aad286.tar.bz2
gentoo-2-7f0ecf4d3ab64a8aa25585fb21aaf64f81aad286.zip
Enable the recorder plugin conditionally (bug #425168)
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/ChangeLog6
-rw-r--r--media-sound/mpd/metadata.xml1
-rw-r--r--media-sound/mpd/mpd-0.17.ebuild25
3 files changed, 21 insertions, 11 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index 8d6c42f8930e..1648fdbd4249 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.286 2012/07/02 15:18:50 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.287 2012/07/11 09:55:18 angelos Exp $
+
+ 11 Jul 2012; Christoph Mende <angelos@gentoo.org> metadata.xml,
+ mpd-0.17.ebuild:
+ Enable the recorder plugin conditionally (bug #425168)
02 Jul 2012; Christoph Mende <angelos@gentoo.org> -mpd-9999.ebuild,
metadata.xml, mpd-0.17.ebuild:
diff --git a/media-sound/mpd/metadata.xml b/media-sound/mpd/metadata.xml
index b8ffbbfa4766..2ec659485f81 100644
--- a/media-sound/mpd/metadata.xml
+++ b/media-sound/mpd/metadata.xml
@@ -24,6 +24,7 @@
<flag name="mpg123">Enable support for mp3 decoding over media-sound/mpg123</flag>
<flag name="network">Enables network streaming support</flag>
<flag name="pipe">Support writing audio to a pipe</flag>
+ <flag name="recorder">Enables output plugin for recording radio streams</flag>
<flag name="sid">Build with SID (Commodore 64 Audio) support</flag>
<flag name="soundcloud">Build plugin to access soundcloud</flag>
<flag name="soup">Use <pkg>net-libs/libsoup</pkg> for HTTP streaming</flag>
diff --git a/media-sound/mpd/mpd-0.17.ebuild b/media-sound/mpd/mpd-0.17.ebuild
index 4d6547585c4b..99c028ad0787 100644
--- a/media-sound/mpd/mpd-0.17.ebuild
+++ b/media-sound/mpd/mpd-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.17.ebuild,v 1.2 2012/07/02 15:18:50 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.17.ebuild,v 1.3 2012/07/11 09:55:18 angelos Exp $
EAPI=4
inherit eutils flag-o-matic linux-info multilib systemd user
@@ -14,14 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~x86 ~x86-fbsd ~x64-macos"
IUSE="aac +alsa ao audiofile bzip2 cdio +curl debug +fifo +ffmpeg flac
fluidsynth +id3tag inotify ipv6 jack lame lastfmradio mms libsamplerate +mad
-mikmod modplug mpg123 musepack +network ogg openal oss pipe pulseaudio sid
-sndfile soundcloud soup sqlite tcpd twolame unicode vorbis wavpack wildmidi
+mikmod modplug mpg123 musepack +network ogg openal oss pipe pulseaudio recorder
+sid sndfile soundcloud soup sqlite tcpd twolame unicode vorbis wavpack wildmidi
zeroconf zip"
-REQUIRED_USE="|| ( alsa ao fifo jack network openal oss pipe pulseaudio )
- || ( aac audiofile ffmpeg flac fluidsynth mad mikmod modplug mpg123 musepack
- ogg flac sid vorbis wavpack wildmidi )
- network? ( || ( audiofile flac lame twolame vorbis ) )
+OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio recorder"
+INPUT_PLUGINS="aac audiofile ffmpeg flac fluidsynth mad mikmod modplug mpg123
+ musepack ogg flac sid vorbis wavpack wildmidi"
+ENCODER_PLUGINS="audiofile flac lame twolame vorbis"
+
+REQUIRED_USE="|| ( ${OUTPUT_PLUGINS} )
+ || ( ${INPUT_PLUGINS} )
+ network? ( || ( ${ENCODER_PLUGINS} ) )
+ recorder? ( || ( ${ENCODER_PLUGINS} ) )
lastfmradio? ( curl )"
RDEPEND="!<sys-cluster/mpich2-1.4_rc2
@@ -87,9 +92,8 @@ src_prepare() {
src_configure() {
local mpdconf="--disable-despotify --disable-documentation --disable-ffado
- --disable-gme --disable-mvp --disable-roar --enable-largefile
- --enable-recorder-output --enable-tcp --enable-un
- --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ --disable-gme --disable-mvp --disable-noar --enable-largefile
+ --enable-tcp --enable-un --docdir=${EPREFIX}/usr/share/doc/${PF}"
if use network; then
mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
@@ -135,6 +139,7 @@ src_configure() {
$(use_enable oss) \
$(use_enable pipe pipe-output) \
$(use_enable pulseaudio pulse) \
+ $(use_enable recorder recorder-output) \
$(use_enable sid sidplay) \
$(use_enable sndfile sndfile) \
$(use_enable soundcloud) \