summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-12 16:55:42 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-12 16:55:42 +0000
commit19ad2e6799189b97e9a6b21d5989eecc5fc33418 (patch)
tree0652514c2b89c11ac4a2c0dabb4c96c316f01a9b /media-sound/mpg123/mpg123-1.14.2.ebuild
parentremove dead code: bug #379659 should be fixed in this release and sync -9999 ... (diff)
downloadgentoo-2-19ad2e6799189b97e9a6b21d5989eecc5fc33418.tar.gz
gentoo-2-19ad2e6799189b97e9a6b21d5989eecc5fc33418.tar.bz2
gentoo-2-19ad2e6799189b97e9a6b21d5989eecc5fc33418.zip
Version bump.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mpg123/mpg123-1.14.2.ebuild')
-rw-r--r--media-sound/mpg123/mpg123-1.14.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/mpg123/mpg123-1.14.2.ebuild b/media-sound/mpg123/mpg123-1.14.2.ebuild
new file mode 100644
index 000000000000..1b639f29a4f4
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.14.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.14.2.ebuild,v 1.1 2012/05/12 16:55:42 radhermit Exp $
+
+EAPI=4
+inherit toolchain-funcs libtool
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://www.mpg123.org/"
+SRC_URI="http://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="3dnow 3dnowext alsa altivec coreaudio ipv6 jack mmx nas oss portaudio pulseaudio sdl sse"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )
+ sys-devel/libtool"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ elibtoolize # for Darwin bundles
+}
+
+src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio="${_audio} ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ else
+ use mmx && _cpu=mmx
+ use 3dnow && _cpu=3dnow
+ use sse && _cpu=x86
+ use 3dnowext && _cpu=x86
+ fi
+
+ econf \
+ --with-optimization=0 \
+ --with-audio="${_audio}" \
+ --with-default-audio=${_output} \
+ --with-cpu=${_cpu} \
+ --enable-network \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}