summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2006-11-14 03:31:37 +0000
committerPeter Johanson <latexer@gentoo.org>2006-11-14 03:31:37 +0000
commit5e3b9dac8af13b4e7c29eb95d7dcdec1cb137518 (patch)
tree3d1449acd26b829efba5905f7a1462d94a3f0c94 /media-sound/muine
parentAdd patch and bump ebuild for it such that users get the patch for bug # 130056 (diff)
downloadgentoo-2-5e3b9dac8af13b4e7c29eb95d7dcdec1cb137518.tar.gz
gentoo-2-5e3b9dac8af13b4e7c29eb95d7dcdec1cb137518.tar.bz2
gentoo-2-5e3b9dac8af13b4e7c29eb95d7dcdec1cb137518.zip
Bump.
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'media-sound/muine')
-rw-r--r--media-sound/muine/ChangeLog7
-rw-r--r--media-sound/muine/files/digest-muine-0.8.63
-rw-r--r--media-sound/muine/muine-0.8.6.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/media-sound/muine/ChangeLog b/media-sound/muine/ChangeLog
index 853f2b12bb6a..34894fe9f61d 100644
--- a/media-sound/muine/ChangeLog
+++ b/media-sound/muine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/muine
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.35 2006/10/24 01:16:12 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.36 2006/11/14 03:31:37 latexer Exp $
+
+*muine-0.8.6 (14 Nov 2006)
+
+ 14 Nov 2006; Peter Johanson <latexer@gentoo.org> +muine-0.8.6.ebuild:
+ Bump.
24 Oct 2006; Peter Johanson <latexer@gentoo.org> muine-0.8.4.ebuild,
muine-0.8.5.ebuild:
diff --git a/media-sound/muine/files/digest-muine-0.8.6 b/media-sound/muine/files/digest-muine-0.8.6
new file mode 100644
index 000000000000..e8accb0477ca
--- /dev/null
+++ b/media-sound/muine/files/digest-muine-0.8.6
@@ -0,0 +1,3 @@
+MD5 8646e439667896423c06cc2fcb67754f muine-0.8.6.tar.gz 725263
+RMD160 58efd00721ba5d6ebabee6be6a7a000b4af159c9 muine-0.8.6.tar.gz 725263
+SHA256 7035fada17007c8434d74b13154d144d93c051ff8c0dbf717bffd0b4709ae9ab muine-0.8.6.tar.gz 725263
diff --git a/media-sound/muine/muine-0.8.6.ebuild b/media-sound/muine/muine-0.8.6.ebuild
new file mode 100644
index 000000000000..01e5b917667b
--- /dev/null
+++ b/media-sound/muine/muine-0.8.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.6.ebuild,v 1.1 2006/11/14 03:31:37 latexer Exp $
+
+inherit gnome2 mono eutils multilib autotools
+
+DESCRIPTION="A music player for GNOME"
+HOMEPAGE="http://muine-player.org/"
+SRC_URI="${HOMEPAGE}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE="xine mad vorbis flac aac"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/mono-1.1
+ >=dev-dotnet/gtk-sharp-2.4.0
+ >=dev-dotnet/gnome-sharp-2.4.0
+ >=dev-dotnet/gnomevfs-sharp-2.4.0
+ >=dev-dotnet/glade-sharp-2.4.0
+ >=dev-dotnet/gconf-sharp-2.4.0
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ !xine? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-base-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ =media-plugins/gst-plugins-gconf-0.10*
+ mad? ( =media-plugins/gst-plugins-mad-0.10* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10* )
+ flac? ( =media-plugins/gst-plugins-flac-0.10* )
+ aac? (
+ =media-plugins/gst-plugins-faad-0.10*
+ >=media-libs/faad2-2.0-r4
+ )
+ )
+ >=media-libs/libid3tag-0.15.0b
+ >=media-libs/libvorbis-1.0
+ sys-libs/gdbm
+ >=gnome-base/gconf-2.0.0
+ >=gnome-base/gnome-vfs-2.0.0
+ >=x11-libs/gtk+-2.6.0
+ >=dev-util/intltool-0.29
+ >=sys-apps/dbus-0.23.2-r1
+ ~media-libs/flac-1.1.2"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/monodoc-1.1.8
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+use xine && \
+ G2CONF="${G2CONF} --enable-gstreamer=no" || \
+ G2CONF="${G2CONF} --enable-gstreamer=yes"
+
+
+G2CONF="${G2CONF} $(use_enable aac faad2)"
+
+USE_DESTDIR=1
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ MAINTAINERS NEWS README TODO"
+
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus mono ; then
+ echo
+ eerror "In order to compile muine, you need to have sys-apps/dbus emerged"
+ eerror "with 'mono' in your USE flags. Please add that flag, re-emerge"
+ eerror "dbus, and then emerge muine."
+ die "sys-apps/dbus is missing the .NET binding."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix the install location of the dbus service file
+ sed -i "s:libdir)/dbus-1.0:datadir)/dbus-1:" \
+ ${S}/data/Makefile.am || die "sed failed"
+
+ intltoolize --force --copy || die "intltoolize failed"
+ eautoreconf
+}
+
+src_compile() {
+ gnome2_src_configure "$@"
+ emake -j1 || die "compile failure"
+}
+
+src_install() {
+ gnome2_src_install "$@"
+
+ insinto /usr/$(get_libdir)/muine/plugins/
+ doins ${S}/plugins/TrayIcon.dll
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Upstream no longer packages the tray icon plugin by default."
+ einfo "The Gentoo ebuilds will continue to install the plugin, if you don't"
+ einfo "want to use the plugin, remove TrayIcon.dll from"
+ einfo "/usr/$(get_libdir)/muine/plugins/"
+}