summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2013-06-07 02:14:48 +0000
committerTimo Gurr <tgurr@gentoo.org>2013-06-07 02:14:48 +0000
commit51d1ad9cd6618bf330edf6d22e7c7d8bd3554fbc (patch)
tree99813578dcf20372f1fb03ca6976ac4215709da8 /media-sound/mumble
parentImprove docs for PYTHON and EPYTHON. (diff)
downloadgentoo-2-51d1ad9cd6618bf330edf6d22e7c7d8bd3554fbc.tar.gz
gentoo-2-51d1ad9cd6618bf330edf6d22e7c7d8bd3554fbc.tar.bz2
gentoo-2-51d1ad9cd6618bf330edf6d22e7c7d8bd3554fbc.zip
Fix building with speech-dispatcher >=0.8 wrt bug #472366.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 5270BA51)
Diffstat (limited to 'media-sound/mumble')
-rw-r--r--media-sound/mumble/ChangeLog6
-rw-r--r--media-sound/mumble/files/mumble-1.2.4-speech-dispatcher.patch49
-rw-r--r--media-sound/mumble/mumble-1.2.4.ebuild6
3 files changed, 59 insertions, 2 deletions
diff --git a/media-sound/mumble/ChangeLog b/media-sound/mumble/ChangeLog
index 4e198b1f6bdf..689cd209610b 100644
--- a/media-sound/mumble/ChangeLog
+++ b/media-sound/mumble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mumble
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.39 2013/06/04 22:06:26 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.40 2013/06/07 02:14:47 tgurr Exp $
+
+ 07 Jun 2013; Timo Gurr <tgurr@gentoo.org> mumble-1.2.4.ebuild,
+ +files/mumble-1.2.4-speech-dispatcher.patch:
+ Fix building with speech-dispatcher >=0.8 wrt bug #472366.
*mumble-1.2.4 (04 Jun 2013)
diff --git a/media-sound/mumble/files/mumble-1.2.4-speech-dispatcher.patch b/media-sound/mumble/files/mumble-1.2.4-speech-dispatcher.patch
new file mode 100644
index 000000000000..3a2c21675a56
--- /dev/null
+++ b/media-sound/mumble/files/mumble-1.2.4-speech-dispatcher.patch
@@ -0,0 +1,49 @@
+From 22d18212acec9e97231a13a6dc02a0c451df9b89 Mon Sep 17 00:00:00 2001
+From: Mikkel Krautz <mikkel@krautz.dk>
+Date: Thu, 6 Jun 2013 22:17:31 +0200
+Subject: [PATCH] mumble.pro: add speech-dispatcher 0.8 compatibiltiy.
+
+Based on initial patch by Timo Gurr <timo.gurr@gmail.com>
+---
+ src/mumble/TextToSpeech_unix.cpp | 6 +++++-
+ src/mumble/mumble.pro | 7 ++++++-
+ 2 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/src/mumble/TextToSpeech_unix.cpp b/src/mumble/TextToSpeech_unix.cpp
+index d0fbb82..6443c07 100644
+--- a/src/mumble/TextToSpeech_unix.cpp
++++ b/src/mumble/TextToSpeech_unix.cpp
+@@ -33,7 +33,11 @@
+ #include "TextToSpeech.h"
+
+ #ifdef USE_SPEECHD
+-#include <libspeechd.h>
++# ifdef USE_SPEECHD_PKGCONFIG
++# include <speech-dispatcher/libspeechd.h>
++# else
++# include <libspeechd.h>
++# endif
+ #endif
+
+ #include "Global.h"
+diff --git a/src/mumble/mumble.pro b/src/mumble/mumble.pro
+index 04f5a36..ff3c02f 100644
+--- a/src/mumble/mumble.pro
++++ b/src/mumble/mumble.pro
+@@ -279,7 +279,12 @@ dbus {
+
+ speechd {
+ DEFINES *= USE_SPEECHD
+- LIBS *= -lspeechd
++ system(pkg-config --atleast-version=0.8 speech-dispatcher) {
++ DEFINES *= USE_SPEECHD_PKGCONFIG
++ PKGCONFIG *= speech-dispatcher
++ } else {
++ LIBS *= -lspeechd
++ }
+ }
+
+ directsound {
+--
+1.8.1.6
+
diff --git a/media-sound/mumble/mumble-1.2.4.ebuild b/media-sound/mumble/mumble-1.2.4.ebuild
index 396864e88e27..dea8f50554c0 100644
--- a/media-sound/mumble/mumble-1.2.4.ebuild
+++ b/media-sound/mumble/mumble-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-1.2.4.ebuild,v 1.1 2013/06/04 22:06:26 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-1.2.4.ebuild,v 1.2 2013/06/07 02:14:47 tgurr Exp $
EAPI="5"
@@ -45,6 +45,10 @@ RDEPEND=">=dev-libs/boost-1.41.0
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.4-speech-dispatcher.patch
+)
+
S="${WORKDIR}/${MY_P}"
src_configure() {