summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:39:04 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:39:04 +0000
commit3e3bf00272b715bd74f667ba2dbf355ee4e633d0 (patch)
tree7bbfcf2fefe879f36ce96a58f079ace62ac1ee8e /media-sound/orpheus
parentFix build with GCC 4.7 (bug #429292). (diff)
downloadgentoo-2-3e3bf00272b715bd74f667ba2dbf355ee4e633d0.tar.gz
gentoo-2-3e3bf00272b715bd74f667ba2dbf355ee4e633d0.tar.bz2
gentoo-2-3e3bf00272b715bd74f667ba2dbf355ee4e633d0.zip
Fix build with GCC 4.7 (bug #430386).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'media-sound/orpheus')
-rw-r--r--media-sound/orpheus/ChangeLog8
-rw-r--r--media-sound/orpheus/files/orpheus-1.6-gcc47.patch15
-rw-r--r--media-sound/orpheus/orpheus-1.6-r2.ebuild5
3 files changed, 24 insertions, 4 deletions
diff --git a/media-sound/orpheus/ChangeLog b/media-sound/orpheus/ChangeLog
index 4c9173e323ac..241e3d8b3f02 100644
--- a/media-sound/orpheus/ChangeLog
+++ b/media-sound/orpheus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/orpheus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/ChangeLog,v 1.31 2012/10/10 06:55:11 nativemad Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/ChangeLog,v 1.32 2013/03/03 06:39:04 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> orpheus-1.6-r2.ebuild,
+ +files/orpheus-1.6-gcc47.patch:
+ Fix build with GCC 4.7 (bug #430386).
10 Oct 2012; Andreas Schuerch <nativemad@gentoo.org> orpheus-1.6-r2.ebuild:
x86 stable, see bug 424962
diff --git a/media-sound/orpheus/files/orpheus-1.6-gcc47.patch b/media-sound/orpheus/files/orpheus-1.6-gcc47.patch
new file mode 100644
index 000000000000..605bb9927760
--- /dev/null
+++ b/media-sound/orpheus/files/orpheus-1.6-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/430386
+
+ src/streamtrack.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/streamtrack.cc
++++ b/src/streamtrack.cc
+@@ -34,6 +34,7 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <unistd.h>
+
+ #include <algorithm>
+
diff --git a/media-sound/orpheus/orpheus-1.6-r2.ebuild b/media-sound/orpheus/orpheus-1.6-r2.ebuild
index 4f9425fe8b1b..c7e68e56046b 100644
--- a/media-sound/orpheus/orpheus-1.6-r2.ebuild
+++ b/media-sound/orpheus/orpheus-1.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/orpheus-1.6-r2.ebuild,v 1.5 2012/10/10 06:55:11 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/orpheus-1.6-r2.ebuild,v 1.6 2013/03/03 06:39:04 dirtyepic Exp $
EAPI=4
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-nolibghttp.patch \
"${FILESDIR}"/${P}-cppflags.patch \
"${FILESDIR}"/${P}-bufsize.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-constify.patch
cp "${S}/config.rpath" "${S}/kkstrtext-0.1/" || die