summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 05:20:08 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 05:20:08 +0000
commit83c31ffb37c57a8804a27f087578c2b327555973 (patch)
tree62a6cd7072471ff2d77d307d3d50686cd8de1a9c /media-sound/phonon
parentmasking kde 4.3 dependencies before adding them to tree (diff)
downloadgentoo-2-83c31ffb37c57a8804a27f087578c2b327555973.tar.gz
gentoo-2-83c31ffb37c57a8804a27f087578c2b327555973.tar.bz2
gentoo-2-83c31ffb37c57a8804a27f087578c2b327555973.zip
version bump, kde 4.3 dep
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/phonon')
-rw-r--r--media-sound/phonon/ChangeLog8
-rw-r--r--media-sound/phonon/phonon-4.4_pre20090520.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/media-sound/phonon/ChangeLog b/media-sound/phonon/ChangeLog
index afed2f6f8762..a242909d36ff 100644
--- a/media-sound/phonon/ChangeLog
+++ b/media-sound/phonon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/phonon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/ChangeLog,v 1.20 2009/06/18 10:52:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/ChangeLog,v 1.21 2009/08/04 05:20:08 wired Exp $
+
+*phonon-4.4_pre20090520 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org>
+ +phonon-4.4_pre20090520.ebuild:
+ version bump. kde 4.3 dep.
18 Jun 2009; Alexis Ballier <aballier@gentoo.org> phonon-4.3.1.ebuild:
keyword ~x86-fbsd
diff --git a/media-sound/phonon/phonon-4.4_pre20090520.ebuild b/media-sound/phonon/phonon-4.4_pre20090520.ebuild
new file mode 100644
index 000000000000..c593438a404a
--- /dev/null
+++ b/media-sound/phonon/phonon-4.4_pre20090520.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/phonon/phonon-4.4_pre20090520.ebuild,v 1.1 2009/08/04 05:20:08 wired Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="KDE multimedia API"
+HOMEPAGE="http://phonon.kde.org"
+SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug gstreamer +xcb +xine"
+
+RDEPEND="
+ !kde-base/phonon-xine
+ !x11-libs/qt-phonon:4
+ >=x11-libs/qt-test-4.4.0:4
+ >=x11-libs/qt-dbus-4.4.0:4
+ >=x11-libs/qt-gui-4.4.0:4
+ >=x11-libs/qt-opengl-4.4.0:4
+ gstreamer? (
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ )
+ xine? (
+ >=media-libs/xine-lib-1.1.15-r1[xcb?]
+ xcb? ( x11-libs/libxcb )
+ )
+"
+DEPEND="${RDEPEND}
+ >=kde-base/automoc-0.9.87
+"
+
+pkg_setup() {
+ if use !xine && use !gstreamer; then
+ die "you must at least select one backend for phonon"
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gstreamer GStreamer)
+ $(cmake-utils_use_with gstreamer GStreamerPlugins)
+ $(cmake-utils_use_with xine)"
+
+ if use xine; then
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with xcb)"
+ else
+ sed -i -e '/xine/d' CMakeLists.txt || die "sed failed"
+ fi
+
+ cmake-utils_src_configure
+}