summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-06-13 15:45:20 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-06-13 15:45:20 +0000
commit6bb7508c4de3c7a8344afb8003a664618e6cdf1b (patch)
tree63a51d24f2cf9d7ee3d7b4886820a5bf674b2d49 /media-sound/picard
parentVersion bump (diff)
downloadgentoo-2-6bb7508c4de3c7a8344afb8003a664618e6cdf1b.tar.gz
gentoo-2-6bb7508c4de3c7a8344afb8003a664618e6cdf1b.tar.bz2
gentoo-2-6bb7508c4de3c7a8344afb8003a664618e6cdf1b.zip
Version bump and added patch for new ffmpeg headers compatibility (bug #223949), thanks to Ben de Groot.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25-gentoo-r3 x86_64)
Diffstat (limited to 'media-sound/picard')
-rw-r--r--media-sound/picard/ChangeLog9
-rw-r--r--media-sound/picard/files/picard-0.10.0_rc1-ffmpeg-headers.patch18
-rw-r--r--media-sound/picard/picard-0.10.0_rc1.ebuild71
3 files changed, 97 insertions, 1 deletions
diff --git a/media-sound/picard/ChangeLog b/media-sound/picard/ChangeLog
index bcefc2f64ccf..2b0750458603 100644
--- a/media-sound/picard/ChangeLog
+++ b/media-sound/picard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/picard
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.9 2008/04/11 12:46:09 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.10 2008/06/13 15:45:20 coldwind Exp $
+
+*picard-0.10.0_rc1 (13 Jun 2008)
+
+ 13 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/picard-0.10.0_rc1-ffmpeg-headers.patch, +picard-0.10.0_rc1.ebuild:
+ Version bump and added patch for new ffmpeg headers compatibility (bug
+ #223949), thanks to Ben de Groot.
11 Apr 2008; Santiago M. Mola <coldwind@gentoo.org> picard-0.9.0.ebuild:
Remove qt-4.2 dep wrt bug #217190
diff --git a/media-sound/picard/files/picard-0.10.0_rc1-ffmpeg-headers.patch b/media-sound/picard/files/picard-0.10.0_rc1-ffmpeg-headers.patch
new file mode 100644
index 000000000000..16733ce1ab36
--- /dev/null
+++ b/media-sound/picard/files/picard-0.10.0_rc1-ffmpeg-headers.patch
@@ -0,0 +1,18 @@
+Source: Imported from Berkano overlay, by Ben de Groot.
+Upstream: Sent, http://bugs.musicbrainz.org/ticket/3777
+Reason: Compatibility with new ffmpeg headers,
+ starting from media-video/ffmpeg-0.4.9_p20080326.
+--- picard-0.10.0rc1-orig/picard/musicdns/avcodec.c 2008-05-29 00:10:50.000000000 +0200
++++ picard-0.10.0rc1/picard/musicdns/avcodec.c 2008-05-29 00:11:17.000000000 +0200
+@@ -24,8 +24,8 @@
+ #define inline __inline
+ #endif
+
+-#include <avcodec.h>
+-#include <avformat.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
+ #include <Python.h>
+
+ #ifdef _WIN32
+
diff --git a/media-sound/picard/picard-0.10.0_rc1.ebuild b/media-sound/picard/picard-0.10.0_rc1.ebuild
new file mode 100644
index 000000000000..7a977454b28f
--- /dev/null
+++ b/media-sound/picard/picard-0.10.0_rc1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/picard-0.10.0_rc1.ebuild,v 1.1 2008/06/13 15:45:20 coldwind Exp $
+
+inherit eutils distutils
+
+MY_P="${P/_/}"
+DESCRIPTION="An improved rewrite/port of the Picard Tagger using Qt"
+HOMEPAGE="http://musicbrainz.org/doc/PicardQt"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdaudio ffmpeg nls"
+
+RDEPEND=">=dev-lang/python-2.4
+ || ( >=dev-lang/python-2.5 >=dev-python/ctypes-0.9 )
+ >=dev-python/PyQt4-4.2
+ >=media-libs/mutagen-1.13
+ cdaudio? ( >=media-libs/libdiscid-0.1.1 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326
+ >=media-libs/libofa-0.9.2 )"
+
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS.txt INSTALL.txt NEWS.txt"
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if ! use ffmpeg; then
+ ewarn "The 'ffmpeg' USE flag is disabled. Acoustic fingerprinting and"
+ ewarn "recognition will not be available."
+ fi
+ if ! use cdaudio; then
+ ewarn "The 'cdaudio' USE flag is disabled. CD index lookup and"
+ ewarn "identification will not be available. You can get audio CD support"
+ ewarn "by installing media-libs/libdiscid."
+ fi
+
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # This raises ffmpeg dep to >=0.4.9_p20080326
+ epatch "${FILESDIR}"/${P}-ffmpeg-headers.patch
+}
+
+src_compile() {
+ ${python} setup.py config || die "setup.py config failed"
+ if ! use ffmpeg; then
+ sed -i -e "s:\(^with-avcodec\ =\ \).*:\1False:" \
+ -e "s:\(^with-libofa\ =\ \).*:\1False:" \
+ build.cfg || die "sed failed"
+ fi
+ ${python} setup.py build $(use nls || echo "--disable-locales") \
+ || die "setup.py build failed"
+}
+
+src_install() {
+ distutils_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ echo
+ elog "You should set the environment variable BROWSER to something like"
+ elog "\"firefox '%s' &\" to let python know which browser to use."
+}