summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-24 12:16:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-24 12:16:21 +0000
commitfc3bfac9bafb202a70281cb61c761c6fabcf5a39 (patch)
treef1c0a29ea15e25e499915f3c2b92e87db4058bab /media-sound/pragha
parentMask klibc because does not work anymore on ppc (diff)
downloadgentoo-2-fc3bfac9bafb202a70281cb61c761c6fabcf5a39.tar.gz
gentoo-2-fc3bfac9bafb202a70281cb61c761c6fabcf5a39.tar.bz2
gentoo-2-fc3bfac9bafb202a70281cb61c761c6fabcf5a39.zip
Version bump.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound/pragha')
-rw-r--r--media-sound/pragha/ChangeLog8
-rw-r--r--media-sound/pragha/pragha-1.1.2.1.ebuild59
2 files changed, 65 insertions, 2 deletions
diff --git a/media-sound/pragha/ChangeLog b/media-sound/pragha/ChangeLog
index 7626e14c96e0..6225a8d33a3d 100644
--- a/media-sound/pragha/ChangeLog
+++ b/media-sound/pragha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pragha
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.26 2013/02/25 09:49:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/ChangeLog,v 1.27 2013/08/24 12:16:21 ssuominen Exp $
+
+*pragha-1.1.2.1 (24 Aug 2013)
+
+ 24 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +pragha-1.1.2.1.ebuild:
+ Version bump.
*pragha-1.1.2 (25 Feb 2013)
@@ -96,4 +101,3 @@
18 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> +pragha-1.0_rc2.ebuild:
Initial commit wrt #295323 by Marco Simeone and Fabian Köster
-
diff --git a/media-sound/pragha/pragha-1.1.2.1.ebuild b/media-sound/pragha/pragha-1.1.2.1.ebuild
new file mode 100644
index 000000000000..192c5c7dfe38
--- /dev/null
+++ b/media-sound/pragha/pragha-1.1.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pragha/pragha-1.1.2.1.ebuild,v 1.1 2013/08/24 12:16:21 ssuominen Exp $
+
+EAPI=5
+inherit flag-o-matic xfconf
+
+DESCRIPTION="A lightweight music player (with support for the Xfce desktop environment)"
+HOMEPAGE="http://pragha.wikispaces.com/ http://github.com/matiasdelellis/pragha"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm +playlist"
+
+COMMON_DEPEND="dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ >=dev-libs/keybinder-0.2.2:0
+ dev-libs/libcdio-paranoia
+ media-libs/gst-plugins-base:0.10
+ >=media-libs/libcddb-1.3.2
+ >=media-libs/taglib-1.7.1
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.10
+ playlist? ( >=dev-libs/totem-pl-parser-2.26 )
+ glyr? ( >=media-libs/glyr-1.0.1 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:0.10"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(use_enable playlist totem-plparser)
+ )
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-g -ggdb -O0::' configure || die
+ xfconf_src_prepare
+}
+
+src_configure() {
+ # src/cdda.h should #include config.h to get this defined:
+ # http://github.com/matiasdelellis/pragha/issues/46
+ append-cppflags -DHAVE_PARANOIA_NEW_INCLUDES
+ xfconf_src_configure
+}