summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-10-20 16:15:56 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-10-20 16:15:56 +0000
commitad9b989d7f113d5a7416a29a1e203f64ab456eee (patch)
treeb5d0e0a4714cb233b8d6023638d9200c338b7613 /media-sound/pulseaudio
parent[bump] dev-perl/Mouse-0.970.0 (diff)
downloadgentoo-2-ad9b989d7f113d5a7416a29a1e203f64ab456eee.tar.gz
gentoo-2-ad9b989d7f113d5a7416a29a1e203f64ab456eee.tar.bz2
gentoo-2-ad9b989d7f113d5a7416a29a1e203f64ab456eee.zip
New stable releases. Bunch of bug fixes. Remove old versions since some of the problems were license related.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/ChangeLog10
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-1.1-python3-fix.patch122
-rw-r--r--media-sound/pulseaudio/pulseaudio-1.0-r1.ebuild206
-rw-r--r--media-sound/pulseaudio/pulseaudio-1.1.ebuild (renamed from media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild)4
4 files changed, 133 insertions, 209 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index a2ef8ac701ea..260a7d41bd77 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.250 2011/10/08 11:28:50 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.251 2011/10/20 16:15:56 ford_prefect Exp $
+
+*pulseaudio-1.1 (20 Oct 2011)
+
+ 20 Oct 2011; Arun Raghavan <ford_prefect@gentoo.org>
+ -pulseaudio-1.0-r1.ebuild, -pulseaudio-1.0-r2.ebuild, +pulseaudio-1.1.ebuild,
+ +files/pulseaudio-1.1-python3-fix.patch:
+ New stable releases. Bunch of bug fixes. Remove old versions since some of
+ the problems were license related.
*pulseaudio-1.0-r2 (08 Oct 2011)
diff --git a/media-sound/pulseaudio/files/pulseaudio-1.1-python3-fix.patch b/media-sound/pulseaudio/files/pulseaudio-1.1-python3-fix.patch
new file mode 100644
index 000000000000..52017c3cad48
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-1.1-python3-fix.patch
@@ -0,0 +1,122 @@
+commit b453e13edef8be95d70d837466e911b883faf476
+Author: Maarten Bosmans <mkbosmans@gmail.com>
+Date: Mon Oct 10 12:28:22 2011 +0200
+
+ qpaeq: Make it python3 and python2 compatible
+
+diff --git a/src/utils/qpaeq b/src/utils/qpaeq
+index a8a9fda..951e70f 100755
+--- a/src/utils/qpaeq
++++ b/src/utils/qpaeq
+@@ -22,12 +22,11 @@ try:
+ from PyQt4 import QtGui,QtCore
+ import dbus.mainloop.qt
+ import dbus
+-except ImportError,e:
+- print 'There was an error importing need libraries'
+- print 'Make sure you haveqt4 and dbus forthon installed'
+- print 'The error that occured was'
+- print '\t%s' %(str(e))
+- import sys
++except ImportError as e:
++ sys.stderr.write('There was an error importing need libraries\n'
++ 'Make sure you haveqt4 and dbus forthon installed\n'
++ 'The error that occured was:\n'
++ '\t%s\n' % (str(e)))
+ sys.exit(-1)
+
+ from functools import partial
+@@ -47,10 +46,10 @@ def connect():
+ server_lookup = bus.get_object('org.PulseAudio1', '/org/pulseaudio/server_lookup1')
+ address = server_lookup.Get('org.PulseAudio.ServerLookup1', 'Address', dbus_interface='org.freedesktop.DBus.Properties')
+ return dbus.connection.Connection(address)
+- except Exception,e:
+- print 'There was an error connecting to pulseaudio, please make sure you have the pulseaudio dbus'
+- print 'and equalizer modules loaded, exiting...'
+- import sys
++ except Exception as e:
++ sys.stderr.write('There was an error connecting to pulseaudio, '
++ 'please make sure you have the pulseaudio dbus '
++ 'and equalizer modules loaded, exiting...\n')
+ sys.exit(-1)
+
+
+@@ -148,7 +147,7 @@ class QPaeq(QtGui.QWidget):
+
+ self.channel_box.clear()
+ self.channel_box.addItem('All',self.filter_state.channels)
+- for i in xrange(self.filter_state.channels):
++ for i in range(self.filter_state.channels):
+ self.channel_box.addItem('%d' %(i+1,),i)
+ self.setMinimumSize(self.sizeHint())
+
+@@ -221,7 +220,7 @@ class QPaeq(QtGui.QWidget):
+ self.filter_state.readback()
+
+ #TODO: add back in preamp!
+- #print frequencies
++ #print(frequencies)
+ #main_layout.addLayout(self.create_slider(partial(self.update_coefficient,0),
+ # 'Preamp')[0]
+ #)
+@@ -243,7 +242,7 @@ class QPaeq(QtGui.QWidget):
+ self.update_profiles()
+ self.update_sinks()
+ def update_profiles(self):
+- #print 'update profiles called!'
++ #print('update profiles called!')
+ manager_props=dbus.Interface(self.manager_obj,dbus_interface=prop_iface)
+ self.profiles=manager_props.Get(self.manager_iface,'Profiles')
+ self.profile_box.blockSignals(True)
+@@ -262,7 +261,7 @@ class QPaeq(QtGui.QWidget):
+ self.sink_box.blockSignals(False)
+ self.sink_box.setMinimumSize(self.sink_box.sizeHint())
+ def read_filter(self):
+- #print self.filter_frequencies
++ #print(self.filter_frequencies)
+ self.filter_state.readback()
+ def reset(self):
+ coefs=dbus.Array([1/math.sqrt(2.0)]*(self.filter_state.filter_rate//2+1))
+@@ -480,18 +479,16 @@ class FilterState(QtCore.QObject):
+ return [0]+xs+[self.sample_rate//2]
+ def _set_frequency_values(self,freqs):
+ self.frequencies=freqs
+- #print 'base',self.frequencies
+- self.filter_frequencies=map(lambda x: int(round(x)), \
+- self.translate_rates(self.filter_rate,self.sample_rate,
+- self.frequencies) \
+- )
++ #print('base',self.frequencies)
++ self.filter_frequencies=[int(round(x)) for x in self.translate_rates(self.filter_rate,self.sample_rate,
++ self.frequencies)]
+ self.coefficients=[0.0]*len(self.frequencies)
+ self.preamp=1.0
+ def set_frequency_values(self,freqs):
+ self._set_frequency_values(self.freq_proper(freqs))
+ @staticmethod
+ def translate_rates(dst,src,rates):
+- return list(map(lambda x: x*dst/src,rates))
++ return list([x*dst/src for x in rates])
+ def seed(self):
+ self.sink.SeedFilter(self.channel,self.filter_frequencies,self.coefficients,self.preamp)
+ self.sync_timer.start(SYNC_TIMEOUT)
+@@ -504,7 +501,7 @@ class FilterState(QtCore.QObject):
+ self.sink.SetFilter(self.channel,dbus.Array(coefs),self.preamp)
+ self.sync_timer.start(SYNC_TIMEOUT)
+ def save_state(self):
+- print 'saving state'
++ print('saving state')
+ self.sink.SaveState()
+ def load_profile(self,profile):
+ self.sink.LoadProfile(self.channel,dbus.String(profile))
+@@ -540,8 +537,8 @@ def subdivide(xs, t_points):
+ p_drop=len(xs)-t_points
+ p_drop_left=p_drop//2
+ p_drop_right=p_drop-p_drop_left
+- #print 'xs',xs
+- #print 'dropping %d, %d left, %d right' %(p_drop,p_drop_left,p_drop_right)
++ #print('xs',xs)
++ #print('dropping %d, %d left, %d right' %(p_drop,p_drop_left,p_drop_right))
+ c=len(xs)//2
+ left=xs[0:p_drop_left*2:2]+xs[p_drop_left*2:c]
+ right=list(reversed(xs[c:]))
diff --git a/media-sound/pulseaudio/pulseaudio-1.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-1.0-r1.ebuild
deleted file mode 100644
index 7e71c5ee48e5..000000000000
--- a/media-sound/pulseaudio/pulseaudio-1.0-r1.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-1.0-r1.ebuild,v 1.1 2011/09/28 14:31:56 ford_prefect Exp $
-
-EAPI=4
-
-inherit eutils libtool flag-o-matic versionator
-
-DESCRIPTION="A networked sound server with an advanced plugin system"
-HOMEPAGE="http://www.pulseaudio.org/"
-
-SRC_URI="http://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc"
-
-RDEPEND="app-admin/eselect-esd
- X? (
- >=x11-libs/libX11-1.4.0
- >=x11-libs/libxcb-1.6
- >=x11-libs/xcb-util-0.3.1
- x11-libs/libSM
- x11-libs/libICE
- x11-libs/libXtst
- )
- caps? ( sys-libs/libcap )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
- alsa? ( >=media-libs/alsa-lib-1.0.19 )
- glib? ( >=dev-libs/glib-2.4.0 )
- avahi? ( >=net-dns/avahi-0.6.12[dbus] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.117 )
- tcpd? ( sys-apps/tcp-wrappers )
- lirc? ( app-misc/lirc )
- dbus? ( >=sys-apps/dbus-1.0.0 )
- gnome? ( >=gnome-base/gconf-2.4.0 )
- bluetooth? (
- >=net-wireless/bluez-4
- >=sys-apps/dbus-1.0.0
- )
- asyncns? ( net-libs/libasyncns )
- udev? ( || ( >=sys-fs/udev-171[hwdb] >=sys-fs/udev-143[extras] ) )
- realtime? ( sys-auth/rtkit )
- equalizer? ( sci-libs/fftw:3.0 )
- orc? ( >=dev-lang/orc-0.4.9 )
- >=media-libs/audiofile-0.2.6-r1
- >=media-libs/speex-1.2_rc1
- >=media-libs/libsndfile-1.0.20
- sys-libs/gdbm
- dev-libs/json-c
- >=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- X? (
- x11-proto/xproto
- >=x11-libs/libXtst-1.0.99.2
- )
- dev-libs/libatomic_ops
- dev-util/pkgconfig
- system-wide? ( || ( dev-util/unifdef sys-freebsd/freebsd-ubin ) )
- dev-util/intltool"
-
-# alsa-utils dep is for the alsasound init.d script (see bug #155707)
-# bluez dep is for the bluetooth init.d script
-RDEPEND="${RDEPEND}
- X? ( gnome-extra/gnome-audio )
- system-wide? (
- sys-apps/openrc
- alsa? ( media-sound/alsa-utils )
- bluetooth? ( >=net-wireless/bluez-4 )
- )"
-
-pkg_setup() {
- enewgroup audio 18 # Just make sure it exists
- enewgroup pulse-access
- enewgroup pulse
- enewuser pulse -1 -1 /var/run/pulse pulse,audio
-}
-
-src_configure() {
- # It's a binutils bug, once I can find time to fix that I'll add a
- # proper dependency and fix this up. — flameeyes
- append-ldflags $(no-as-needed)
-
- econf \
- --enable-largefile \
- $(use_enable glib glib2) \
- --disable-solaris \
- $(use_enable asyncns) \
- $(use_enable oss oss-output) \
- $(use_enable alsa) \
- $(use_enable lirc) \
- $(use_enable tcpd tcpwrap) \
- $(use_enable jack) \
- $(use_enable lirc) \
- $(use_enable avahi) \
- --disable-hal \
- $(use_enable dbus) \
- $(use_enable gnome gconf) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable bluetooth bluez) \
- $(use_enable X x11) \
- $(use_enable test default-build-tests) \
- $(use_enable udev) \
- $(use_enable ipv6) \
- $(use_with caps) \
- $(use_with equalizer fftw) \
- --localstatedir="${EPREFIX}"/var \
- --with-database=gdbm \
- --with-udev-rules-dir="${EPREFIX}/lib/udev/rules.d"
-
- if use doc; then
- pushd doxygen
- doxygen doxygen.conf
- popd
- fi
-}
-
-src_test() {
- # We avoid running the toplevel check target because that will run
- # po/'s tests too, and they are broken. Officially, it should work
- # with intltool 0.41, but that doesn't look like a stable release.
- emake -C src check
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
-
- # Drop the script entirely if X is disabled
- use X || rm "${ED}"/usr/bin/start-pulseaudio-x11
-
- if use system-wide; then
- newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
-
- use_define() {
- local define=${2:-$(echo $1 | tr '[:lower:]' '[:upper:]')}
-
- use "$1" && echo "-D$define" || echo "-U$define"
- }
-
- unifdef $(use_define avahi) \
- $(use_define alsa) \
- $(use_define bluetooth) \
- $(use_define udev) \
- "${FILESDIR}/pulseaudio.init.d-5" \
- > "${T}/pulseaudio"
-
- doinitd "${T}/pulseaudio"
- fi
-
- use avahi && sed -i -e '/module-zeroconf-publish/s:^#::' "${ED}/etc/pulse/default.pa"
-
- dodoc README todo
-
- if use doc; then
- pushd doxygen/html
- dohtml *
- popd
- fi
-
- # Create the state directory
- use prefix || diropts -o pulse -g pulse -m0755
- keepdir /var/run/pulse
-
- find "${D}" -name '*.la' -delete
-}
-
-pkg_postinst() {
- if use system-wide; then
- elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
- elog "This support is enabled by starting the pulseaudio init.d ."
- elog "To be able to access that you need to be in the group pulse-access."
- elog "If you choose to use this feature, please make sure that you"
- elog "really want to run PulseAudio this way:"
- elog " http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
- elog "For more information about system-wide support, please refer to:"
- elog " http://pulseaudio.org/wiki/SystemWideInstance"
- if use gnome ; then
- elog
- elog "By enabling gnome USE flag, you enabled gconf support. Please note"
- elog "that you might need to remove the gnome USE flag or disable the"
- elog "gconf module on /etc/pulse/system.pa to be able to use PulseAudio"
- elog "with a system-wide instance."
- fi
- fi
- if use bluetooth; then
- elog
- elog "The Bluetooth proximity module is not enabled in the default"
- elog "configuration file. If you do enable it, you'll have to have"
- elog "your Bluetooth controller enabled and inserted at bootup or"
- elog "PulseAudio will refuse to start."
- fi
- if use alsa; then
- local pkg="media-plugins/alsa-plugins"
- if has_version ${pkg} && ! has_version "${pkg}[pulseaudio]"; then
- elog
- elog "You have alsa support enabled so you probably want to install"
- elog "${pkg} with pulseaudio support to have"
- elog "alsa using applications route their sound through pulseaudio"
- fi
- fi
-
- eselect esd update --if-unset
-}
diff --git a/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild b/media-sound/pulseaudio/pulseaudio-1.1.ebuild
index 2c008395bd98..ff5db0a0481e 100644
--- a/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild,v 1.1 2011/10/08 11:28:50 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-1.1.ebuild,v 1.1 2011/10/20 16:15:56 ford_prefect Exp $
EAPI=4
@@ -80,7 +80,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}-version-fix.patch"
+ epatch "${FILESDIR}/${P}-python3-fix.patch"
}
src_configure() {