summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-02-18 23:33:23 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-02-18 23:33:23 +0000
commit7d16ff1fa35b004509b4794cfec6c3550ea684e4 (patch)
treecc98ceb4d5958770c0994c4ab3a52b0d727b98e3 /media-sound/pympd/pympd-0.06.ebuild
parentVersion bump. (diff)
downloadgentoo-2-7d16ff1fa35b004509b4794cfec6c3550ea684e4.tar.gz
gentoo-2-7d16ff1fa35b004509b4794cfec6c3550ea684e4.tar.bz2
gentoo-2-7d16ff1fa35b004509b4794cfec6c3550ea684e4.zip
Fixed the build procedure, so we don't need to sed the Makefile. Added a warning about removing ~/.pympd. Thanks go to Natan 'whatah' Zohar.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-sound/pympd/pympd-0.06.ebuild')
-rw-r--r--media-sound/pympd/pympd-0.06.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-sound/pympd/pympd-0.06.ebuild b/media-sound/pympd/pympd-0.06.ebuild
index e7bfe62120fd..880c21f47043 100644
--- a/media-sound/pympd/pympd-0.06.ebuild
+++ b/media-sound/pympd/pympd-0.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pympd/pympd-0.06.ebuild,v 1.1 2006/02/18 21:55:00 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pympd/pympd-0.06.ebuild,v 1.2 2006/02/18 23:33:23 ticho Exp $
inherit eutils python
@@ -18,16 +18,12 @@ RDEPEND=">=virtual/python-2.4
DOCS="README"
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s:^PREFIX=.*:PREFIX=/usr:" \
- -e "s:^DESTDIR=.*:DESTDIR=${D}:" \
- Makefile
+src_compile() {
+ make PREFIX="/usr" DESTDIR="${D}"
}
src_install() {
- make install
+ make PREFIX="/usr" DESTDIR="${D}" install
use gnome || cd ${D} && find -iname trayicon.* | xargs rm
@@ -42,6 +38,12 @@ src_install() {
pkg_postinst() {
python_version
python_mod_optimize /usr/lib/python${PYVER}/site-packages/pympd
+
+ echo
+ ewarn
+ ewarn "You need to remove the .pympd directory from your home directory, as new version uses different settings format"
+ ewarn
+ echo
}
pkg_postrm() {