summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-29 12:22:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-29 12:22:55 +0000
commitbfae5c8f7ed81b1524b7d5462a9aff11bcdb12c7 (patch)
treef309ac7549ab8c51937fe6197f6d6b7d62456811 /media-sound/qjackctl
parentAdd new thirdpartymirror: nero. (diff)
downloadgentoo-2-bfae5c8f7ed81b1524b7d5462a9aff11bcdb12c7.tar.gz
gentoo-2-bfae5c8f7ed81b1524b7d5462a9aff11bcdb12c7.tar.bz2
gentoo-2-bfae5c8f7ed81b1524b7d5462a9aff11bcdb12c7.zip
Version bump. Add alsa and debug USE flags. When alsa USE flag is enabled, check for the midi flag on alsa-lib or it will not build. Install a desktop file and move the icon in the right place. Install the documentation.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog12
-rw-r--r--media-sound/qjackctl/files/digest-qjackctl-0.2.223
-rw-r--r--media-sound/qjackctl/qjackctl-0.2.22.ebuild54
3 files changed, 67 insertions, 2 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 844d6984c03e..7991b56be628 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/qjackctl
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.40 2006/10/08 03:18:45 eldad Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.41 2007/06/29 12:22:55 flameeyes Exp $
+
+*qjackctl-0.2.22 (29 Jun 2007)
+
+ 29 Jun 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +qjackctl-0.2.22.ebuild:
+ Version bump. Add alsa and debug USE flags. When alsa USE flag is enabled,
+ check for the midi flag on alsa-lib or it will not build. Install a desktop
+ file and move the icon in the right place. Install the documentation.
*qjackctl-0.2.21 (08 Oct 2006)
diff --git a/media-sound/qjackctl/files/digest-qjackctl-0.2.22 b/media-sound/qjackctl/files/digest-qjackctl-0.2.22
new file mode 100644
index 000000000000..e04ac59cd89a
--- /dev/null
+++ b/media-sound/qjackctl/files/digest-qjackctl-0.2.22
@@ -0,0 +1,3 @@
+MD5 384e69d49c854bf14615752ba097d261 qjackctl-0.2.22.tar.gz 256654
+RMD160 4f9ed30bc9c3a187028d9329cc09b730e6113d00 qjackctl-0.2.22.tar.gz 256654
+SHA256 332b24c1813f3ed711233ceaf570221e80c10ae4cbeba673a397450d9eb40f0a qjackctl-0.2.22.tar.gz 256654
diff --git a/media-sound/qjackctl/qjackctl-0.2.22.ebuild b/media-sound/qjackctl/qjackctl-0.2.22.ebuild
new file mode 100644
index 000000000000..17fe18a359ff
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.2.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.2.22.ebuild,v 1.1 2007/06/29 12:22:55 flameeyes Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="alsa debug"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ $(qt_min_version 3.1.1)
+ media-sound/jack-audio-connection-kit"
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
+ eerror "need to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ # Upstream's configure.ac is broken, assumes that passing any
+ # --(dis|en)able-(feature) means the non-default option.
+
+ use alsa || myconf="${myconf} --disable-alsa-seq"
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ # The icon is installed in the wrong place, move it into a more
+ # proper path.
+ dodir /usr/share/icons/hicolor/32x32/apps
+ mv "${D}/usr/share/icons/${PN}.png" "${D}/usr/share/icons/hicolor/32x32/apps/"
+
+ make_desktop_entry "${PN}" "QjackCtl" "${PN}"
+
+ dodoc README ChangeLog TODO AUTHORS
+}