summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-02 15:32:34 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-02 15:32:34 +0000
commit315210a4a6421e04d111e96b9e20a4d66e9f99ee (patch)
tree44b27fa98aedd5e12eed8296aaea93ddcad4e5e7 /media-sound/qmpdclient
parentRestrict perl to version 5.14 or lower (bug #423997) (diff)
downloadgentoo-2-315210a4a6421e04d111e96b9e20a4d66e9f99ee.tar.gz
gentoo-2-315210a4a6421e04d111e96b9e20a4d66e9f99ee.tar.bz2
gentoo-2-315210a4a6421e04d111e96b9e20a4d66e9f99ee.zip
Apply patch for Qt-4.8 (bug #418937 by Kent Fredric)
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qmpdclient')
-rw-r--r--media-sound/qmpdclient/ChangeLog9
-rw-r--r--media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch40
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild39
3 files changed, 86 insertions, 2 deletions
diff --git a/media-sound/qmpdclient/ChangeLog b/media-sound/qmpdclient/ChangeLog
index 2668239b80d2..2404af9b2e51 100644
--- a/media-sound/qmpdclient/ChangeLog
+++ b/media-sound/qmpdclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qmpdclient
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.90 2012/05/29 19:35:53 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.91 2012/07/02 15:32:34 angelos Exp $
+
+*qmpdclient-1.2.2-r1 (02 Jul 2012)
+
+ 02 Jul 2012; Christoph Mende <angelos@gentoo.org>
+ +files/qmpdclient-1.2.2-qt48.patch, +qmpdclient-1.2.2-r1.ebuild:
+ Apply patch for Qt-4.8 (bug #418937 by Kent Fredric)
29 May 2012; Brent Baude <ranger@gentoo.org> qmpdclient-1.2.2.ebuild:
Marking qmpdclient-1.2.2 ppc for bug 400407
@@ -371,4 +377,3 @@
+qmpdclient-1.0.3.ebuild:
Initial import. Based on an ebuild by Gorch <gorch at 12move.de> and Avuton
Olrich <avuton at gmail.com>. Closes bug #122048.
-
diff --git a/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch b/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch
new file mode 100644
index 000000000000..2eac669c092c
--- /dev/null
+++ b/media-sound/qmpdclient/files/qmpdclient-1.2.2-qt48.patch
@@ -0,0 +1,40 @@
+From 20edef54b109882632f58549d181123b9985d65b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 1 Jun 2012 21:54:10 +1200
+Subject: [PATCH] First attempt at fixing lastfm scrobbling
+
+---
+ src/lastfmsubmitter.cpp | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/lastfmsubmitter.cpp b/src/lastfmsubmitter.cpp
+index cff94bc..a9b6ea9 100644
+--- a/src/lastfmsubmitter.cpp
++++ b/src/lastfmsubmitter.cpp
+@@ -112,7 +112,10 @@ void LastFmSubmitter::scrobbleNp(MPDSong & s) {
+ data += QString("l=%1&").arg(s.secs() >0 ? QString::number(s.secs()) : "100");
+ data += QString("n=%1").arg(QString(QUrl::toPercentEncoding(s.track())));
+ //qDebug() << data;
+- m_netAccess->post(QNetworkRequest(QUrl(m_npUrl)), data.toAscii());
++ QUrl url(m_npUrl);
++ QNetworkRequest request(url);
++ request.setRawHeader("Content-Type", "application/x-www-form-urlencoded");
++ m_netAccess->post(request, data.toAscii());
+ }
+
+ void LastFmSubmitter::scrobbleCurrent() {
+@@ -152,7 +155,10 @@ void LastFmSubmitter::scrobbleQueued() {
+ if (i>0) {
+ //qDebug() << "sending scrobble to " << m_subUrl.toAscii();
+ //qDebug() << "data: " << data.toAscii();
+- m_netAccess->post(QNetworkRequest(QUrl(m_subUrl)), data.toAscii());
++ QUrl url(m_subUrl);
++ QNetworkRequest request(url);
++ request.setRawHeader("Content-Type", "application/x-www-form-urlencoded");
++ m_netAccess->post(request, data.toAscii());
+ m_awaitingScrob = true;
+ }
+ }
+--
+1.7.9.4
+
diff --git a/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild b/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..914ad9cfa50f
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.2.2-r1.ebuild,v 1.1 2012/07/02 15:32:34 angelos Exp $
+
+EAPI=4
+inherit fdo-mime cmake-utils
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-webkit:4
+ x11-libs/qt-xmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README THANKSTO )
+PATCHES=( "${FILESDIR}"/${P}-qt48.patch )
+
+src_prepare() {
+ sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
+ base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }