summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-17 18:40:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-17 18:40:35 +0000
commit67bc8aa878391747cc66964fc1fbe8592d58e3c4 (patch)
tree2cfd620047f8a255429544697aec644f2158bb56 /media-sound/qtscrobbler
parentold (diff)
downloadgentoo-2-67bc8aa878391747cc66964fc1fbe8592d58e3c4.tar.gz
gentoo-2-67bc8aa878391747cc66964fc1fbe8592d58e3c4.tar.bz2
gentoo-2-67bc8aa878391747cc66964fc1fbe8592d58e3c4.zip
Fix old style Qt4 depend
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qtscrobbler')
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.8-r1.ebuild59
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.9.ebuild4
2 files changed, 2 insertions, 61 deletions
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.8-r1.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.8-r1.ebuild
deleted file mode 100644
index 7d3e56d1a196..000000000000
--- a/media-sound/qtscrobbler/qtscrobbler-0.8-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.8-r1.ebuild,v 1.2 2008/08/08 20:59:32 beandog Exp $
-
-EAPI=1
-inherit eutils qt4
-
-MY_PN="qtscrob"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Updates a last.fm profile using information from a supported portable music player"
-HOMEPAGE="http://qtscrob.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cli +qt4"
-
-DEPEND="net-misc/curl
- qt4? ( || ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 ) )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- # Makefile for cli prog does not read CFLAGS env var.
- # This sed fixes this.
- cd "${S}/src/cli"
- sed -i -e "s:CFLAGS =.*:CFLAGS = \$(INCLUDE) `curl-config --cflags` ${CFLAGS}:" Makefile
-}
-
-src_compile() {
- if use cli; then
- cd "${S}/src/cli"
- emake || die "emake cli failed"
- fi
- if use qt4; then
- cd "${S}/src/qt"
- qmake "${MY_PN}.pro" || die "qmake qt4 gui failed"
- emake || die "emake qt4 gui failed"
- fi
-}
-
-src_install() {
- if use cli; then
- cd "${S}/src/cli"
- newbin scrobble-cli qtscrobbler-cli
- fi
- if use qt4; then
- cd "${S}/src/qt"
- newbin qtscrob qtscrobbler
- newicon resources/icons/128.png qtscrobbler.png
- make_desktop_entry qtscrobbler QtScrobbler
- fi
- cd "${S}"
- dodoc AUTHORS CHANGELOG README
-}
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild
index 847a22cf901a..7c67c2cf3fb0 100644
--- a/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild
+++ b/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild,v 1.2 2009/03/15 20:44:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.9.ebuild,v 1.3 2009/12/17 18:40:35 ssuominen Exp $
EAPI=1
inherit eutils qt4
@@ -18,7 +18,7 @@ KEYWORDS="amd64 x86"
IUSE="cli +qt4"
DEPEND="net-misc/curl
- qt4? ( || ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 ) )"
+ x11-libs/qt-gui:4"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"