summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-01-30 12:04:13 +0000
committerPacho Ramos <pacho@gentoo.org>2012-01-30 12:04:13 +0000
commitf0356217be0fc58911fa0651302d71b9adf0f31b (patch)
tree3a9f3b1d51fa3ea7ab35676c0849bb198cc5f184 /media-sound/rhythmbox
parentVerion bump (diff)
downloadgentoo-2-f0356217be0fc58911fa0651302d71b9adf0f31b.tar.gz
gentoo-2-f0356217be0fc58911fa0651302d71b9adf0f31b.tar.bz2
gentoo-2-f0356217be0fc58911fa0651302d71b9adf0f31b.zip
Fix build/running when python3 is main interpreter, bug #401047 by Alexander Sulfrian
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index cbe7d9eae833..9a87365843cd 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.211 2012/01/17 17:05:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.212 2012/01/30 12:04:13 pacho Exp $
+
+ 30 Jan 2012; Pacho Ramos <pacho@gentoo.org> rhythmbox-0.12.8-r1.ebuild:
+ Fix build/running when python3 is main interpreter, bug #401047 by Alexander
+ Sulfrian
17 Jan 2012; Pacho Ramos <pacho@gentoo.org> rhythmbox-2.95.ebuild:
>=x11-libs/gtk+-3.2 is needed, bug #399121 by erhard.furtner and Matthias
diff --git a/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild
index b2a3e9521663..e7823e608e6e 100644
--- a/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild,v 1.18 2012/01/05 06:38:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.8-r1.ebuild,v 1.19 2012/01/30 12:04:13 pacho Exp $
-EAPI="3"
+EAPI="4"
+GNOME_TARBALL_SUFFIX="bz2"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="python? 2"
inherit eutils gnome2 python multilib virtualx
@@ -44,7 +47,6 @@ COMMON_DEPEND=">=dev-libs/glib-2.18:2
musicbrainz? ( media-libs/musicbrainz:3
media-libs/musicbrainz:1 )
python? (
- >=dev-lang/python-2.4.2
|| (
>=dev-lang/python-2.5
dev-python/celementtree )
@@ -137,6 +139,11 @@ pkg_setup() {
--disable-vala"
export GST_INSPECT=/bin/true
+
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -152,6 +159,8 @@ src_prepare() {
# Fix building with recent glibc, bug #333373
epatch "${FILESDIR}/${P}-namespace-conflict.patch"
+
+ use python && python_convert_shebangs -r 2 .
}
src_compile() {