summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-14 06:09:29 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-14 06:09:29 +0000
commitbf24dc3b2abb54ed0727f88348073f34e39bd0e1 (patch)
tree13e435c5c1ba2bfed487c1bef36dc583a539eadb /media-sound/sound-juicer
parentAdd ~amd64-linux keyword. (diff)
downloadgentoo-2-bf24dc3b2abb54ed0727f88348073f34e39bd0e1.tar.gz
gentoo-2-bf24dc3b2abb54ed0727f88348073f34e39bd0e1.tar.bz2
gentoo-2-bf24dc3b2abb54ed0727f88348073f34e39bd0e1.zip
Version bump to the first stable gtk3-based release. Note that unlike older versions, in 3.4 encoding profiles cannot be customized.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/sound-juicer')
-rw-r--r--media-sound/sound-juicer/ChangeLog9
-rw-r--r--media-sound/sound-juicer/sound-juicer-3.4.0.ebuild64
2 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/sound-juicer/ChangeLog b/media-sound/sound-juicer/ChangeLog
index 239465b3dd6b..743b989ad320 100644
--- a/media-sound/sound-juicer/ChangeLog
+++ b/media-sound/sound-juicer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/sound-juicer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.216 2012/02/26 09:38:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/ChangeLog,v 1.217 2012/04/14 06:09:29 tetromino Exp $
+
+*sound-juicer-3.4.0 (14 Apr 2012)
+
+ 14 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +sound-juicer-3.4.0.ebuild:
+ Version bump to the first stable gtk3-based release. Note that unlike older
+ versions, in 3.4 encoding profiles cannot be customized.
26 Feb 2012; Pacho Ramos <pacho@gentoo.org> -sound-juicer-2.32.0.ebuild,
sound-juicer-2.32.0-r1.ebuild:
diff --git a/media-sound/sound-juicer/sound-juicer-3.4.0.ebuild b/media-sound/sound-juicer/sound-juicer-3.4.0.ebuild
new file mode 100644
index 000000000000..2e3e5434ec95
--- /dev/null
+++ b/media-sound/sound-juicer/sound-juicer-3.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sound-juicer/sound-juicer-3.4.0.ebuild,v 1.1 2012/04/14 06:09:29 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="CD ripper for GNOME"
+HOMEPAGE="http://www.burtonini.com/blog/computers/sound-juicer/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.90:3
+ media-libs/libcanberra[gtk3]
+ >=app-cdr/brasero-2.90
+ >=gnome-base/gconf-2:2
+ sys-apps/dbus
+
+ media-libs/libdiscid
+ media-libs/musicbrainz:4
+
+ >=media-libs/gstreamer-0.10.32:0.10
+ >=media-libs/gst-plugins-base-0.10:0.10"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs[cdda,udev]
+ >=media-plugins/gst-plugins-gconf-0.10:0.10
+ >=media-plugins/gst-plugins-gio-0.10:0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10:0.10
+ >=media-plugins/gst-plugins-cdio-0.10:0.10 )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/scrollkeeper-0.3.5
+ app-text/gnome-doc-utils
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+pkg_setup() {
+ # GST_INSPECT needed to get around some sandboxing checks
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ GST_INSPECT=$(type -P true)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If ${PN} does not rip to some music format, please check your USE flags"
+ ewarn "on media-libs/libgnome-media-profiles and media-plugins/gst-plugins-meta"
+ ewarn
+ ewarn "The list of audio encoding profiles in ${P} is non-customizable."
+ ewarn "A possible workaround is to rip to flac using ${PN}, and convert to"
+ ewarn "your desired format using a separate tool."
+}