summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-01-10 22:25:28 +0000
committerHanno Böck <hanno@gentoo.org>2013-01-10 22:25:28 +0000
commit40f1fe5bafbe6d8f09927261092c64ef1e0ef88e (patch)
tree39119e086a14562ac222b938fcd47bb3a6e73c73 /media-sound/soundconverter
parentunar 1.5 version bump (diff)
downloadgentoo-2-40f1fe5bafbe6d8f09927261092c64ef1e0ef88e.tar.gz
gentoo-2-40f1fe5bafbe6d8f09927261092c64ef1e0ef88e.tar.bz2
gentoo-2-40f1fe5bafbe6d8f09927261092c64ef1e0ef88e.zip
soundconverter bump and opus-support.
(Portage version: 2.1.11.39/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/ChangeLog10
-rw-r--r--media-sound/soundconverter/metadata.xml3
-rw-r--r--media-sound/soundconverter/soundconverter-2.0.4.ebuild71
3 files changed, 82 insertions, 2 deletions
diff --git a/media-sound/soundconverter/ChangeLog b/media-sound/soundconverter/ChangeLog
index 40fadac3a2f6..b877506a1f2a 100644
--- a/media-sound/soundconverter/ChangeLog
+++ b/media-sound/soundconverter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/soundconverter
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.30 2012/10/17 11:07:19 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.31 2013/01/10 22:25:28 hanno Exp $
+
+*soundconverter-2.0.4 (10 Jan 2013)
+
+ 10 Jan 2013; Hanno Boeck <hanno@gentoo.org> +soundconverter-2.0.4.ebuild,
+ metadata.xml:
+ Bump, adds opus support.
17 Oct 2012; <ago@gentoo.org> soundconverter-2.0.3.ebuild:
Stable for amd64, wrt bug #433317
diff --git a/media-sound/soundconverter/metadata.xml b/media-sound/soundconverter/metadata.xml
index 37678311fd47..796134f8a2c7 100644
--- a/media-sound/soundconverter/metadata.xml
+++ b/media-sound/soundconverter/metadata.xml
@@ -3,4 +3,7 @@
<pkgmetadata>
<herd>gstreamer</herd>
<maintainer><email>hanno@gentoo.org</email></maintainer>
+<use>
+<flag name='opus'>Enable Opus audio codec support</flag>
+</use>
</pkgmetadata>
diff --git a/media-sound/soundconverter/soundconverter-2.0.4.ebuild b/media-sound/soundconverter/soundconverter-2.0.4.ebuild
new file mode 100644
index 000000000000..a0a11bf2bc86
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-2.0.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/soundconverter-2.0.4.ebuild,v 1.1 2013/01/10 22:25:28 hanno Exp $
+
+EAPI=4
+
+GCONF_DEBUG=no
+PYTHON_DEPEND="2:2.7"
+
+inherit gnome2 multilib python
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="http://soundconverter.org/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac flac mp3 opus vorbis"
+
+RDEPEND="dev-python/gconf-python
+ dev-python/gnome-vfs-python
+ =dev-python/gst-python-0.10*
+ dev-python/pygobject:2
+ >=dev-python/pygtk-2.12
+ dev-python/libgnome-python
+ gnome-base/libglade
+ aac? (
+ =media-plugins/gst-plugins-faac-0.10*
+ =media-plugins/gst-plugins-faad-0.10*
+ )
+ flac? ( =media-plugins/gst-plugins-flac-0.10* )
+ mp3? (
+ =media-plugins/gst-plugins-lame-0.10*
+ =media-plugins/gst-plugins-mad-0.10*
+ =media-plugins/gst-plugins-taglib-0.10*
+ )
+ vorbis? (
+ =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10*
+ )
+ opus? (
+ =media-plugins/gst-plugins-opus-0.10*
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile
+ python_convert_shebangs -r 2 .
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ gnome2_pkg_postrm
+}