summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-07-14 12:16:22 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-07-14 12:16:22 +0000
commit6f263cee280b0db5255aa056ed2858317f960eb3 (patch)
tree1f5481842fc7a3d134e9ce3952ff982fff785706 /media-sound/streamtranscoder
parentarm stable, bug #416233 (diff)
downloadgentoo-2-6f263cee280b0db5255aa056ed2858317f960eb3.tar.gz
gentoo-2-6f263cee280b0db5255aa056ed2858317f960eb3.tar.bz2
gentoo-2-6f263cee280b0db5255aa056ed2858317f960eb3.zip
fix build time issues wrt bug #426488
(Portage version: 2.2.0_alpha117/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/streamtranscoder')
-rw-r--r--media-sound/streamtranscoder/ChangeLog8
-rw-r--r--media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch59
-rw-r--r--media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild21
3 files changed, 81 insertions, 7 deletions
diff --git a/media-sound/streamtranscoder/ChangeLog b/media-sound/streamtranscoder/ChangeLog
index 134a6442035f..f08424580ebe 100644
--- a/media-sound/streamtranscoder/ChangeLog
+++ b/media-sound/streamtranscoder/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/streamtranscoder
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamtranscoder/ChangeLog,v 1.9 2007/07/30 14:17:00 gustavoz Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamtranscoder/ChangeLog,v 1.10 2012/07/14 12:16:22 hasufell Exp $
+
+ 14 Jul 2012; Julian Ospald <hasufell@gentoo.org>
+ streamtranscoder-1.2.4.ebuild, +files/streamtranscoder-1.2.4-build.patch:
+ fix build time issues wrt bug #426488
30 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org>
streamtranscoder-3.1.11.ebuild:
diff --git a/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
new file mode 100644
index 000000000000..07128bb95596
--- /dev/null
+++ b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
@@ -0,0 +1,59 @@
+--- configure.in
++++ configure.in
+@@ -83,22 +83,29 @@
+
+ dnl -- configure options --
+
+-XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!(Perhaps you need --with-ogg-prefix=/usr/local)))
+-XIPH_PATH_VORBIS(, AC_MSG_ERROR(must have Vorbis installed!(Perhaps you need --with-vorbis-prefix=/usr/local)))
+-AM_PATH_CURL(,,AC_MSG_ERROR(must have libcurl installed!))
+-AM_PATH_MAD(, AC_MSG_ERROR(must have libmad installed!))
+-AM_PATH_LAME(, AC_MSG_ERROR(must have libmp3lame installed!))
++PKG_CHECK_MODULES([OGG],[ogg])
++PKG_CHECK_MODULES([VORBIS],[vorbis])
++PKG_CHECK_MODULES([VORBISENC],[vorbisenc])
++PKG_CHECK_MODULES([VORBISFILE],[vorbisfile])
++PKG_CHECK_MODULES([CURL],[libcurl])
++PKG_CHECK_MODULES([MAD],[mad])
++
++AC_PATH_PROG([LAME],[lame])
+
+ dnl Make substitutions
+
+ AC_SUBST(MAD_CFLAGS)
+ AC_SUBST(MAD_LIBS)
+ AC_SUBST(LAME_CFLAGS)
+-AC_SUBST(LAME_LIBS)
++AC_SUBST([LAME_LIBS],[-lmp3lame])
+ AC_SUBST(OGG_CFLAGS)
+ AC_SUBST(VORBIS_CFLAGS)
++AC_SUBST(VORBISENC_CFLAGS)
++AC_SUBST(VORBISFILE_CFLAGS)
+ AC_SUBST(OGG_LIBS)
+ AC_SUBST(VORBIS_LIBS)
++AC_SUBST(VORBISENC_LIBS)
++AC_SUBST(VORBISFILE_LIBS)
+ AC_SUBST(LIBTOOL_DEPS)
+ AC_SUBST(OPT)
+ AC_SUBST(LIBS)
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -17,5 +17,6 @@
+
+ INCLUDES = -I$(srcdir)/liboddcast -I$(srcdir)/libtranscoder
+
+-install-hook:
+- cp transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
++install-data-hook:
++ $(INSTALL) -d $(DESTDIR)$(sysconfdir)
++ $(INSTALL) -m644 transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
+--- src/libtranscoder/transcurl.cpp
++++ src/libtranscoder/transcurl.cpp
+@@ -18,7 +18,6 @@
+ #include <winsock2.h>
+ #endif
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include "transcurl.h"
+ #include "cbuffer.h"
diff --git a/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild b/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild
index 80f1bf8ab4cc..f20c77ceeed2 100644
--- a/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild
+++ b/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild
@@ -1,23 +1,34 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild,v 1.5 2005/08/07 12:52:48 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamtranscoder/streamtranscoder-1.2.4.ebuild,v 1.6 2012/07/14 12:16:22 hasufell Exp $
-IUSE=""
+EAPI=4
+
+inherit autotools eutils
DESCRIPTION="Command line application to transcode shoutcast/icecast streams to different bitrates"
HOMEPAGE="http://www.oddsock.org"
SRC_URI="http://www.oddsock.org/tools/streamTranscoder/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
-DEPEND=">=media-libs/libogg-1.1
+RDEPEND=">=media-libs/libogg-1.1
>=media-libs/libvorbis-1.0.1-r2
>=media-sound/lame-3.96
>=media-libs/libmad-0.15.1b
>=net-misc/curl-7.11.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
src_install() {
- make DESTDIR="${D}" install || die
+ default
dodoc AUTHORS README
}