summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-25 10:38:00 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-25 10:38:00 +0000
commitfd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101 (patch)
tree4e7f14334f287473b1bec3ca6121b697f39e1c40 /media-sound/trommler/trommler-3.7.ebuild
parentFixed bug #161926, thanks to Daniel Klaffenbach, Tom Dexter and Francisco Llo... (diff)
downloadgentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.tar.gz
gentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.tar.bz2
gentoo-2-fd4f6e620ed9a3a7ebf1ce26bcd42624dcd4b101.zip
Version bump to GTK+-2.0 version, install desktop entry, smp2wav script, use toolchain-funcs, and more.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/trommler/trommler-3.7.ebuild')
-rw-r--r--media-sound/trommler/trommler-3.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/trommler/trommler-3.7.ebuild b/media-sound/trommler/trommler-3.7.ebuild
new file mode 100644
index 000000000000..68fd54d2f069
--- /dev/null
+++ b/media-sound/trommler/trommler-3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/trommler/trommler-3.7.ebuild,v 1.1 2007/07/25 10:38:00 drac Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN/t/T}
+
+DESCRIPTION="GTK+ based drum machine."
+HOMEPAGE="http://muth.org/Robert/Trommler"
+SRC_URI="http://muth.org/Robert/${MY_PN}/${P/-/.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc sox"
+
+RDEPEND=">=x11-libs/gtk+-2
+ sox? ( media-sound/sox )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/${MY_PN}
+
+src_compile() {
+ emake export.h || die "emake export.h failed."
+ emake CFLAGS="${CFLAGS} $(pkg-config --cflags gtk+-2.0)" \
+ CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} wav2smp playsample
+ use sox && dobin smp2wav
+ insinto /usr/share/${PN}/Drums
+ doins Drums/*.smp
+ insinto /usr/share/${PN}/Songs
+ doins Songs/*.sng
+ dodoc CHANGES README
+ use doc && dohtml index.html style.css
+ make_desktop_entry ${PN} Trommler
+}