summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-11 07:44:16 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-11 07:44:16 +0000
commit0348826bf83072c7b6e01aec97c99754419c291f (patch)
tree4ea1391491a0cbcc42d343606eb231e670aaf4cd /media-sound/vitunes/vitunes-2.3.ebuild
parentRemove old. (diff)
downloadgentoo-2-0348826bf83072c7b6e01aec97c99754419c291f.tar.gz
gentoo-2-0348826bf83072c7b6e01aec97c99754419c291f.tar.bz2
gentoo-2-0348826bf83072c7b6e01aec97c99754419c291f.zip
Initial import.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/vitunes/vitunes-2.3.ebuild')
-rw-r--r--media-sound/vitunes/vitunes-2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/vitunes/vitunes-2.3.ebuild b/media-sound/vitunes/vitunes-2.3.ebuild
new file mode 100644
index 000000000000..13f95384c6f2
--- /dev/null
+++ b/media-sound/vitunes/vitunes-2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vitunes/vitunes-2.3.ebuild,v 1.1 2012/01/11 07:44:15 radhermit Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A curses media indexer and player for vi users"
+HOMEPAGE="http://vitunes.org/"
+SRC_URI="http://vitunes.org/files/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/taglib
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ || ( media-video/mplayer media-video/mplayer2 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-time-header.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -f Makefile.linux
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc DEVELOPERS.txt add_urls.sh
+}