summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-03-23 20:41:08 +0000
committerChristoph Mende <angelos@gentoo.org>2012-03-23 20:41:08 +0000
commit525e649e396f8ee99215c3bbe45a252a59043583 (patch)
tree538c4aac5bdbac645ec729ccb1bd3b484c7be922 /media-sound/xnoise
parentTemp mask current nvidia-drivers (diff)
downloadgentoo-2-525e649e396f8ee99215c3bbe45a252a59043583.tar.gz
gentoo-2-525e649e396f8ee99215c3bbe45a252a59043583.tar.bz2
gentoo-2-525e649e396f8ee99215c3bbe45a252a59043583.zip
Version bump, update live ebuild
(Portage version: 2.2.0_alpha94/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/xnoise')
-rw-r--r--media-sound/xnoise/ChangeLog10
-rw-r--r--media-sound/xnoise/xnoise-0.1.31.ebuild65
-rw-r--r--media-sound/xnoise/xnoise-9999.ebuild26
3 files changed, 84 insertions, 17 deletions
diff --git a/media-sound/xnoise/ChangeLog b/media-sound/xnoise/ChangeLog
index de6dba2aa251..b8dd9c919497 100644
--- a/media-sound/xnoise/ChangeLog
+++ b/media-sound/xnoise/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xnoise
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/ChangeLog,v 1.15 2011/12/18 10:26:44 angelos Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/ChangeLog,v 1.16 2012/03/23 20:41:08 angelos Exp $
+
+*xnoise-0.1.31 (23 Mar 2012)
+
+ 23 Mar 2012; Christoph Mende <angelos@gentoo.org> +xnoise-0.1.31.ebuild,
+ xnoise-9999.ebuild:
+ Version bump, update live ebuild
*xnoise-0.1.30 (18 Dec 2011)
diff --git a/media-sound/xnoise/xnoise-0.1.31.ebuild b/media-sound/xnoise/xnoise-0.1.31.ebuild
new file mode 100644
index 000000000000..54190be94229
--- /dev/null
+++ b/media-sound/xnoise/xnoise-0.1.31.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-0.1.31.ebuild,v 1.1 2012/03/23 20:41:08 angelos Exp $
+
+EAPI=4
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of
+features"
+HOMEPAGE="http://www.xnoise-media-player.com/"
+SRC_URI="https://github.com/downloads/shuerhaaken/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lastfm libnotify +lyrics"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.28:2
+ dev-libs/libxml2:2
+ media-libs/gst-plugins-base:0.10
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ lastfm? ( net-libs/libsoup:2.4 )
+ libnotify? ( x11-libs/libnotify )
+ lyrics? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ econf \
+ --enable-soundmenu2 \
+ $(use_enable lastfm) \
+ $(use_enable libnotify notifications) \
+ $(use_enable lyrics chartlyrics) \
+ $(use_enable lyrics leoslyrics) \
+ $(use_enable lyrics lyricsfly) \
+ $(use_enable lyrics lyricwiki)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+ rm -rf "${ED}"/usr/share/${PN}/license || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/xnoise/xnoise-9999.ebuild b/media-sound/xnoise/xnoise-9999.ebuild
index 46e80bd1f8d0..07f41f0c3592 100644
--- a/media-sound/xnoise/xnoise-9999.ebuild
+++ b/media-sound/xnoise/xnoise-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-9999.ebuild,v 1.5 2011/12/18 10:26:44 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xnoise/xnoise-9999.ebuild,v 1.6 2012/03/23 20:41:08 angelos Exp $
EAPI=4
-inherit fdo-mime gnome2-utils mercurial
+inherit fdo-mime gnome2-utils git-2
DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of
features"
HOMEPAGE="http://www.xnoise-media-player.com/"
-EHG_REPO_URI="https://xnoise.googlecode.com/hg/"
+EGIT_REPO_URI="git://github.com/shuerhaaken/${PN}.git"
LICENSE="GPL-2"
SLOT="0"
@@ -16,20 +16,18 @@ KEYWORDS=""
IUSE="+lastfm libnotify +lyrics"
RDEPEND="dev-db/sqlite:3
- >=dev-libs/glib-2.26:2
- dev-libs/libunique:1
+ >=dev-libs/glib-2.28:2
dev-libs/libxml2:2
media-libs/gst-plugins-base:0.10
media-libs/gstreamer:0.10
media-libs/taglib
x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
+ x11-libs/gtk+:3
lastfm? ( net-libs/libsoup:2.4 )
libnotify? ( x11-libs/libnotify )
lyrics? ( net-libs/libsoup:2.4 )"
DEPEND="${RDEPEND}
- dev-lang/vala:0.12
+ dev-lang/vala:0.16
dev-util/intltool
dev-util/pkgconfig
gnome-base/gnome-common:3
@@ -43,16 +41,14 @@ src_prepare() {
}
src_configure() {
- VALAC=$(type -p valac-0.12) \
+ VALAC=$(type -p valac-0.16) \
econf \
- --disable-soundmenu \
--enable-soundmenu2 \
$(use_enable lastfm) \
$(use_enable libnotify notifications) \
- $(use_enable lyrics leoslyrics) \
- $(use_enable lyrics lyricsfly) \
- $(use_enable lyrics lyricwiki) \
- $(use_enable lyrics chartlyrics)
+ $(use_enable lyrics azlyrics) \
+ $(use_enable lyrics chartlyrics) \
+ $(use_enable lyrics lyricwiki)
}
src_install() {