summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-06-28 23:16:25 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-06-28 23:16:25 +0000
commit000c61361a72855647afe1f4c3e7416efff1f16f (patch)
treefdac53b6f8b7a08c53bacf0190480ee7f87d80da /media-sound
parentVersion bump, remove old. (diff)
downloadgentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.tar.gz
gentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.tar.bz2
gentoo-2-000c61361a72855647afe1f4c3e7416efff1f16f.zip
Version bump and patch by me to fix compilation with gcc-4.3 and 4.4; bug #251259
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tapestrea/ChangeLog11
-rw-r--r--media-sound/tapestrea/files/tapestrea-0.1.0.5-gcc44.patch33
-rw-r--r--media-sound/tapestrea/tapestrea-0.1.0.5.ebuild89
3 files changed, 131 insertions, 2 deletions
diff --git a/media-sound/tapestrea/ChangeLog b/media-sound/tapestrea/ChangeLog
index 0a95d40f8551..a9bac5066263 100644
--- a/media-sound/tapestrea/ChangeLog
+++ b/media-sound/tapestrea/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/tapestrea
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/ChangeLog,v 1.2 2008/04/28 15:36:43 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/ChangeLog,v 1.3 2009/06/28 23:16:25 halcy0n Exp $
+
+*tapestrea-0.1.0.5 (27 Jun 2009)
+
+ 27 Jun 2009; Mark Loeser <halcy0n@gentoo.org> +tapestrea-0.1.0.5.ebuild,
+ +files/tapestrea-0.1.0.5-gcc44.patch:
+ Version bump and patch by me to fix compilation with gcc-4.3 and 4.4; bug
+ #251259
28 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix metadata.xml.
diff --git a/media-sound/tapestrea/files/tapestrea-0.1.0.5-gcc44.patch b/media-sound/tapestrea/files/tapestrea-0.1.0.5-gcc44.patch
new file mode 100644
index 000000000000..ca6e0370c957
--- /dev/null
+++ b/media-sound/tapestrea/files/tapestrea-0.1.0.5-gcc44.patch
@@ -0,0 +1,33 @@
+diff -ur tapestrea-0.1.0.5-orig/scripting/chuck-1.2.1.2/src/util_string.h tapestrea-0.1.0.5/scripting/chuck-1.2.1.2/src/util_string.h
+--- tapestrea-0.1.0.5-orig/scripting/chuck-1.2.1.2/src/util_string.h 2009-06-27 19:06:03.000000000 -0400
++++ tapestrea-0.1.0.5/scripting/chuck-1.2.1.2/src/util_string.h 2009-06-27 19:06:54.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include "chuck_def.h"
+ #include <string>
+ #include <vector>
++#include <cstdio>
+
+
+ // itoa
+diff -ur tapestrea-0.1.0.5-orig/src/taps_birdbrain.cpp tapestrea-0.1.0.5/src/taps_birdbrain.cpp
+--- tapestrea-0.1.0.5-orig/src/taps_birdbrain.cpp 2009-06-27 19:06:18.000000000 -0400
++++ tapestrea-0.1.0.5/src/taps_birdbrain.cpp 2009-06-27 17:49:18.000000000 -0400
+@@ -35,6 +35,7 @@
+ #include "taps_birdbrain.h"
+ #include "util_thread.h"
+ #include <stdarg.h>
++#include <cstdio>
+
+ // for getcwd and chdir
+ #ifdef __PLATFORM_WIN32__
+diff -ur tapestrea-0.1.0.5-orig/src/ui_audiofx.cpp tapestrea-0.1.0.5/src/ui_audiofx.cpp
+--- tapestrea-0.1.0.5-orig/src/ui_audiofx.cpp 2009-06-27 19:06:18.000000000 -0400
++++ tapestrea-0.1.0.5/src/ui_audiofx.cpp 2009-06-27 17:49:18.000000000 -0400
+@@ -36,6 +36,7 @@
+ #include "taps_birdbrain.h"
+ #include "ui_audiofx.h"
+ #include <iostream>
++#include <cstdio>
+ using namespace std;
+
+ // Start FxStk
diff --git a/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
new file mode 100644
index 000000000000..17988d33c5d1
--- /dev/null
+++ b/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tapestrea/tapestrea-0.1.0.5.ebuild,v 1.1 2009/06/28 23:16:25 halcy0n Exp $
+
+EAPI="1"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Techniques + Paradigms for Expressive Synthesis, Transformation, Rendering of Environmental Audio"
+HOMEPAGE="http://taps.cs.princeton.edu/"
+SRC_URI="http://taps.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oss jack +alsa doc"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile
+ virtual/glut
+ virtual/opengl
+ virtual/glu
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ local cnt=0
+ use jack && cnt="$((${cnt} + 1))"
+ use alsa && cnt="$((${cnt} + 1))"
+ use oss && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -eq 0 ]] ; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ elif [[ "${cnt}" -ne 1 ]] ; then
+ ewarn "You have set ${P} to use multiple audio engine."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc44.patch"
+}
+
+src_compile() {
+ local backend
+ if use jack; then
+ backend="jack"
+ elif use alsa; then
+ backend="alsa"
+ elif use oss; then
+ backend="oss"
+ fi
+ einfo "Compiling against ${backend}"
+
+ # when compile with athlon or athlon-xp flags
+ # chuck crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ cd "${S}/scripting/chuck-1.2.1.2/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin src/taps
+
+ dodoc AUTHORS BUGS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
+ if use doc; then
+ for dir in `find examples/* -type d -maxdepth 0`; do
+ docinto $dir
+ dodoc `find $dir/* -type f -maxdepth 0`
+ for dir2 in `find $dir/* -type d -maxdepth 0`; do
+ docinto $dir2
+ dodoc `find $dir2/* -type f -maxdepth 0`
+ done
+ done
+ docinto doc
+ dodoc doc/*
+ fi
+}