summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-20 14:47:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-20 14:47:17 +0000
commit058a330ccf4d5fa1bf48ec45c4213ccd13e1468f (patch)
treea66f894631565be8fa8ca017c5bebb2e0f5f5e9c /media-sound
parentVersion bump, thank jbergstroem for report. Moved maintenance to bazaar herd. (diff)
downloadgentoo-2-058a330ccf4d5fa1bf48ec45c4213ccd13e1468f.tar.gz
gentoo-2-058a330ccf4d5fa1bf48ec45c4213ccd13e1468f.tar.bz2
gentoo-2-058a330ccf4d5fa1bf48ec45c4213ccd13e1468f.zip
Version bump wrt #287703, thanks to Alex Dedul for reporting.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/exaile/ChangeLog8
-rw-r--r--media-sound/exaile/exaile-0.3.0.1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 1a965540a196..50199e04e6ab 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.62 2009/09/07 12:42:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.63 2009/10/20 14:47:17 ssuominen Exp $
+
+*exaile-0.3.0.1 (20 Oct 2009)
+
+ 20 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +exaile-0.3.0.1.ebuild:
+ Version bump wrt #287703, thanks to Alex Dedul for reporting.
07 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
-exaile-0.3.0_alpha3-r1.ebuild, exaile-0.3.0.ebuild,
diff --git a/media-sound/exaile/exaile-0.3.0.1.ebuild b/media-sound/exaile/exaile-0.3.0.1.ebuild
new file mode 100644
index 000000000000..0970e8658742
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0.1.ebuild,v 1.1 2009/10/20 14:47:17 ssuominen Exp $
+
+EAPI=2
+inherit eutils fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/0.3.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb hal libnotify +libsexy nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.12
+ >=dev-lang/python-2.5[sqlite]
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ hal? ( sys-apps/hal )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.0-Makefile.patch \
+ "${FILESDIR}"/${PN}-0.3.0-Makefile-2.patch
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die
+ fi
+}
+
+src_install() {
+ local _no_locale
+ use nls || _no_locale=_no_locale
+
+ emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+ install${_no_locale} || die
+
+ dodoc README
+
+ insinto /usr/share/exaile/data
+ doins -r data/migrations || die "doins failed"
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}