summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-06 14:13:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-06 14:13:17 +0000
commit0fc039a3fe422875cdc690c17a9c350a898418c4 (patch)
treebb5f8c176f49ddd6a06377f0ea060576bdd93733 /media-sound
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-0fc039a3fe422875cdc690c17a9c350a898418c4.tar.gz
gentoo-2-0fc039a3fe422875cdc690c17a9c350a898418c4.tar.bz2
gentoo-2-0fc039a3fe422875cdc690c17a9c350a898418c4.zip
Initial commit wrt #94477, thanks to Thomas Kuther and others.
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mac/ChangeLog10
-rw-r--r--media-sound/mac/files/mac-3.99.4.5-gcc44.patch27
-rw-r--r--media-sound/mac/mac-3.99.4.5.ebuild45
-rw-r--r--media-sound/mac/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/media-sound/mac/ChangeLog b/media-sound/mac/ChangeLog
new file mode 100644
index 000000000000..86dd86757466
--- /dev/null
+++ b/media-sound/mac/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/mac
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.5 2009/10/06 14:13:16 ssuominen Exp $
+
+*mac-3.99.4.5 (06 Oct 2009)
+
+ 06 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> +mac-3.99.4.5.ebuild,
+ +files/mac-3.99.4.5-gcc44.patch:
+ Initial commit wrt #94477, thanks to Thomas Kuther and others.
+
diff --git a/media-sound/mac/files/mac-3.99.4.5-gcc44.patch b/media-sound/mac/files/mac-3.99.4.5-gcc44.patch
new file mode 100644
index 000000000000..acd4a04b6d0c
--- /dev/null
+++ b/media-sound/mac/files/mac-3.99.4.5-gcc44.patch
@@ -0,0 +1,27 @@
+diff -ur mac-3.99-u4-b5.orig/src/MACLib/APELink.cpp mac-3.99-u4-b5/src/MACLib/APELink.cpp
+--- mac-3.99-u4-b5.orig/src/MACLib/APELink.cpp 2006-06-01 12:00:57.000000000 +0300
++++ mac-3.99-u4-b5/src/MACLib/APELink.cpp 2009-10-06 16:53:19.000000000 +0300
+@@ -63,10 +63,10 @@
+ if (pData != NULL)
+ {
+ // parse out the information
+- char * pHeader = strstr(pData, APE_LINK_HEADER);
+- char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
+- char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
+- char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
++ const char * pHeader = strstr(pData, APE_LINK_HEADER);
++ const char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
++ const char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
++ const char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
+
+ if (pHeader && pImageFile && pStartBlock && pFinishBlock)
+ {
+@@ -81,7 +81,7 @@
+
+ // get the path
+ char cImageFile[MAX_PATH + 1]; int nIndex = 0;
+- char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
++ const char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
+ while ((*pImageCharacter != 0) && (*pImageCharacter != '\r') && (*pImageCharacter != '\n'))
+ cImageFile[nIndex++] = *pImageCharacter++;
+ cImageFile[nIndex] = 0;
diff --git a/media-sound/mac/mac-3.99.4.5.ebuild b/media-sound/mac/mac-3.99.4.5.ebuild
new file mode 100644
index 000000000000..8fc69e203b69
--- /dev/null
+++ b/media-sound/mac/mac-3.99.4.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.ebuild,v 1.1 2009/10/06 14:13:16 ssuominen Exp $
+
+EAPI=2
+inherit eutils multilib versionator
+
+MY_P=${PN}-$(get_version_component_range 1-2)-u$(get_version_component_range 3)-b$(get_version_component_range 4)
+
+DESCRIPTION="Monkey's Audio Codecs"
+HOMEPAGE="http://supermmx.org/linux/mac/"
+SRC_URI="http://supermmx.org/resources/linux/${PN}/${MY_P}.tar.gz"
+
+LICENSE="mac"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmx"
+
+RDEPEND=""
+DEPEND="sys-apps/sed
+ mmx? ( dev-lang/yasm )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ sed -i -e 's:-O3::' configure || die
+}
+
+src_configure() {
+ local mmx=no
+ use mmx && mmx=yes
+
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ --enable-assembly=${mmx}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO src/*.txt
+ dohtml src/Readme.htm
+ find "${D}"/usr/$(get_libdir) -name '*.la' -delete
+}
diff --git a/media-sound/mac/metadata.xml b/media-sound/mac/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/mac/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>