summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-07-13 17:58:55 +0000
committerJonathan Smith <smithj@gentoo.org>2005-07-13 17:58:55 +0000
commit1d733a8f2eb48de9deb0567c1b72e18d55405aa7 (patch)
tree0a8469d201d2ce13f2192cc1a7633eb63ca2ad8d /media-sound
parentadd useflags for net-dialup/isdn4k-utils (diff)
downloadgentoo-2-1d733a8f2eb48de9deb0567c1b72e18d55405aa7.tar.gz
gentoo-2-1d733a8f2eb48de9deb0567c1b72e18d55405aa7.tar.bz2
gentoo-2-1d733a8f2eb48de9deb0567c1b72e18d55405aa7.zip
#98736: version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/moc/ChangeLog7
-rw-r--r--media-sound/moc/files/digest-moc-2.3.01
-rw-r--r--media-sound/moc/moc-2.3.0.ebuild42
3 files changed, 49 insertions, 1 deletions
diff --git a/media-sound/moc/ChangeLog b/media-sound/moc/ChangeLog
index ed71fb92118b..c400ef5732c5 100644
--- a/media-sound/moc/ChangeLog
+++ b/media-sound/moc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/moc
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/ChangeLog,v 1.15 2005/04/18 19:13:29 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/ChangeLog,v 1.16 2005/07/13 17:58:55 smithj Exp $
+
+*moc-2.3.0 (13 Jul 2005)
+
+ 13 Jul 2005; Jonathan Smith <smithj@gentoo.org> +moc-2.3.0.ebuild:
+ #98736: version bump
*moc-2.2.0-r1 (18 Apr 2005)
diff --git a/media-sound/moc/files/digest-moc-2.3.0 b/media-sound/moc/files/digest-moc-2.3.0
new file mode 100644
index 000000000000..39cf534260a9
--- /dev/null
+++ b/media-sound/moc/files/digest-moc-2.3.0
@@ -0,0 +1 @@
+MD5 3d5d152c28f6e40162058fc1566c8109 moc-2.3.0.tar.bz2 402954
diff --git a/media-sound/moc/moc-2.3.0.ebuild b/media-sound/moc/moc-2.3.0.ebuild
new file mode 100644
index 000000000000..7a06e2e66e9e
--- /dev/null
+++ b/media-sound/moc/moc-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/moc-2.3.0.ebuild,v 1.1 2005/07/13 17:58:55 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Music On Console - ncurses interface for playing audio files"
+HOMEPAGE="http://moc.daper.net/"
+SRC_URI="ftp://ftp.daper.net/pub/soft/${PN}/stable/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="flac mad oss vorbis"
+
+DEPEND="media-libs/libao
+ media-libs/libsndfile
+ sys-libs/ncurses
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad sys-libs/zlib media-libs/libid3tag )
+ vorbis? ( media-libs/libvorbis )"
+
+src_compile() {
+ local myconf
+ use flac || myconf="${myconf} --without-flac"
+ use mad || myconf="${myconf} --without-mp3"
+ use vorbis || myconf="${myconf} --without-ogg"
+ use oss || myconf="${myconf} --without-oss"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "The binary was renamed due to conflicts with moc"
+ einfo "from the QT project. Its new name is mocp."
+}