summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-16 08:48:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-16 08:48:28 +0000
commit336647165607dc4c450cc12036a80dd369430d32 (patch)
tree4f146282aa03f8ee838deff522c72bc63b692626 /media-sound
parentRessurect changelog and remove old. (diff)
downloadgentoo-2-336647165607dc4c450cc12036a80dd369430d32.tar.gz
gentoo-2-336647165607dc4c450cc12036a80dd369430d32.tar.bz2
gentoo-2-336647165607dc4c450cc12036a80dd369430d32.zip
Reduce versions around.
(Portage version: 2.2.0_alpha105/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xwax/xwax-0.8.ebuild84
-rw-r--r--media-sound/xwax/xwax-0.9.ebuild87
-rw-r--r--media-sound/xwax/xwax-1.1.ebuild83
3 files changed, 0 insertions, 254 deletions
diff --git a/media-sound/xwax/xwax-0.8.ebuild b/media-sound/xwax/xwax-0.8.ebuild
deleted file mode 100644
index 809361157601..000000000000
--- a/media-sound/xwax/xwax-0.8.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-0.8.ebuild,v 1.5 2011/04/04 12:33:26 scarabeus Exp $
-
-EAPI=3
-inherit toolchain-funcs
-
-DESCRIPTION="Digital vinyl emulation software"
-HOMEPAGE="http://www.xwax.co.uk/"
-SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-# These make sure the user can decode the files he or she cares about by
-# setting appropriate runtime depends and (perhaps) configuring the import
-# script
-IUSE_XWAX_DECODERS="xwax_decoders_aac xwax_decoders_cd xwax_decoders_flac \
- +xwax_decoders_mp3 xwax_decoders_ogg xwax_decoders_misc"
-IUSE="alsa jack ${IUSE_XWAX_DECODERS}"
-
-RDEPEND="media-libs/libsdl
- media-libs/sdl-ttf
- media-fonts/dejavu
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- xwax_decoders_aac? ( media-libs/faad2 )
- xwax_decoders_cd? ( media-sound/cdparanoia )
- xwax_decoders_flac? ( media-libs/flac )
- xwax_decoders_mp3? ( || ( media-sound/mpg123 media-sound/mpg321 ) )
- xwax_decoders_ogg? ( media-sound/vorbis-tools )
- xwax_decoders_misc? ( virtual/ffmpeg )"
-DEPEND="${RDEPEND}"
-
-DOCS="README CHANGES"
-
-src_prepare() {
- # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
- # the Makefile
- sed -i -e 's:\(^CFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- -e 's:\(^LDFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- Makefile || die "sed failed"
-}
-
-src_configure() {
- tc-export CC
- econf \
- $(use_enable alsa) \
- $(use_enable jack)
-}
-
-src_compile() {
- # EXECDIR is the default directory in which xwax will look for
- # the 'xwax-import' and 'xwax-scan' scripts
- emake PREFIX="${EROOT}usr" EXECDIR="${EROOT}usr/bin"
-}
-
-src_install() {
- # This is easier than setting all the environment variables
- # needed, running the sed script required to get the man directory
- # correct, and removing the GPL-2 after a 'make install' run
- dobin xwax || die "failed to install xwax"
- newbin import xwax-import || die "failed to install xwax-import"
- newbin scan xwax-scan || die "failed to install xwax-scan"
- doman xwax.1 || die "failed to install man page"
-
- # Replace any decoder commands in the import script, if necessary
- if use xwax_decoders_mp3; then
- # mpg123 is upstream's default
- if has_version media-sound/mpg123; then
- TO="mpg123"
- FROM="mpg321"
- # Otherwise, use mpg321
- else
- TO="mpg321"
- FROM="mpg123"
- fi
- debug-print "found ${TO}"
- sed -i -e "s:${FROM}:${TO}:g" "${D}/usr/bin/xwax-import" || \
- die "problem converting xwax-import to use ${TO}"
- fi
-
- dodoc ${DOCS} || die "failed to install docs"
-}
diff --git a/media-sound/xwax/xwax-0.9.ebuild b/media-sound/xwax/xwax-0.9.ebuild
deleted file mode 100644
index 3bf3d4fdb97e..000000000000
--- a/media-sound/xwax/xwax-0.9.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-0.9.ebuild,v 1.1 2011/05/07 17:50:00 nixphoeni Exp $
-
-EAPI=4
-inherit toolchain-funcs
-
-DESCRIPTION="Digital vinyl emulation software"
-HOMEPAGE="http://www.xwax.co.uk/"
-SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa jack oss cdda mp3 +fallback"
-REQUIRED_USE="|| ( cdda mp3 fallback )
- || ( alsa jack oss )"
-
-RDEPEND="media-libs/libsdl
- media-libs/sdl-ttf
- media-fonts/dejavu
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- cdda? ( media-sound/cdparanoia )
- mp3? ( || ( media-sound/mpg123 media-sound/mpg321 ) )
- fallback? ( virtual/ffmpeg )"
-DEPEND="${RDEPEND}"
-
-DOCS="README CHANGES"
-
-pkg_setup() {
- ewarn "Please note that XWAX_DECODERS is deprecated in favor of USE flags."
- ewarn "Sorry for the inconvenience."
-}
-
-src_prepare() {
- # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
- # the Makefile
- # Also replace VERSION so we don't have to depend on git...
- sed -i -e 's:\(^CFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- -e 's:\(^LDFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- -e "s:\(^VERSION =\).*:\1 ${PV}:" \
- Makefile || die "sed failed"
-
- # Replace any decoder commands in the import script, if necessary
- if [[ `use mp3` ]]; then
- # mpg123 is upstream's default
- if has_version media-sound/mpg123; then
- TO="mpg123"
- FROM="mpg321"
- # Otherwise, use mpg321
- else
- TO="mpg321"
- FROM="mpg123"
- fi
- debug-print "found ${TO}"
- sed -i -e "s:${FROM}:${TO}:g" import || \
- die "problem converting xwax-import to use ${TO}"
- fi
-}
-
-src_configure() {
- tc-export CC
- econf \
- --prefix "${EROOT}usr" \
- $(use_enable alsa) \
- $(use_enable jack) \
- $(use_enable oss)
-}
-
-src_compile() {
- # EXECDIR is the default directory in which xwax will look for
- # the 'xwax-import' and 'xwax-scan' scripts
- emake EXECDIR="${EROOT}usr/bin"
-}
-
-src_install() {
- # This is easier than setting all the environment variables
- # needed, running the sed script required to get the man directory
- # correct, and removing the GPL-2 after a 'make install' run
- dobin xwax || die "failed to install xwax"
- newbin import xwax-import || die "failed to install xwax-import"
- newbin scan xwax-scan || die "failed to install xwax-scan"
- doman xwax.1 || die "failed to install man page"
-
- dodoc ${DOCS} || die "failed to install docs"
-}
diff --git a/media-sound/xwax/xwax-1.1.ebuild b/media-sound/xwax/xwax-1.1.ebuild
deleted file mode 100644
index bdf8e23ad853..000000000000
--- a/media-sound/xwax/xwax-1.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-1.1.ebuild,v 1.1 2012/01/30 01:14:47 nixphoeni Exp $
-
-EAPI=4
-inherit toolchain-funcs
-
-DESCRIPTION="Digital vinyl emulation software"
-HOMEPAGE="http://www.xwax.co.uk/"
-SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa jack oss cdda mp3 +fallback"
-REQUIRED_USE="|| ( cdda mp3 fallback )
- || ( alsa jack oss )"
-
-RDEPEND="sys-libs/glibc
- media-libs/libsdl
- media-libs/sdl-ttf
- media-fonts/dejavu
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- cdda? ( media-sound/cdparanoia )
- mp3? ( || ( media-sound/mpg123 media-sound/mpg321 ) )
- fallback? ( virtual/ffmpeg )"
-DEPEND="${RDEPEND}"
-
-DOCS="README CHANGES"
-
-src_prepare() {
- # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
- # the Makefile
- # Also remove the dependency on the .version target so we don't need
- # git just to build
- sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
- -e 's/^xwax\.o:.*\.version//' \
- Makefile || die "sed failed"
-
- # Replace any decoder commands in the import script, if necessary
- if [[ `use mp3` ]]; then
- # mpg123 is upstream's default
- if has_version media-sound/mpg123; then
- TO="mpg123"
- FROM="mpg321"
- # Otherwise, use mpg321
- else
- TO="mpg321"
- FROM="mpg123"
- fi
- debug-print "found ${TO}"
- sed -i -e "s:${FROM}:${TO}:g" import || \
- die "problem converting xwax-import to use ${TO}"
- fi
-}
-
-src_configure() {
- tc-export CC
- econf \
- --prefix "${EROOT}usr" \
- $(use_enable alsa) \
- $(use_enable jack) \
- $(use_enable oss)
-}
-
-src_compile() {
- # EXECDIR is the default directory in which xwax will look for
- # the 'xwax-import' and 'xwax-scan' scripts
- emake EXECDIR="\$(BINDIR)" VERSION="${PV}"
-}
-
-src_install() {
- # This is easier than setting all the environment variables
- # needed, running the sed script required to get the man directory
- # correct, and removing the GPL-2 after a 'make install' run
- dobin xwax || die "failed to install xwax"
- newbin import xwax-import || die "failed to install xwax-import"
- newbin scan xwax-scan || die "failed to install xwax-scan"
- doman xwax.1 || die "failed to install man page"
-
- dodoc ${DOCS} || die "failed to install docs"
-}