summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-31 11:33:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-31 11:33:29 +0000
commit3e8d89356c572fc379157743e46bf5c83bf7308e (patch)
treec71bb47f9de45e0f75ea21a71247274f62e42117 /media-sound
parentVersion bump and remove old. (diff)
downloadgentoo-2-3e8d89356c572fc379157743e46bf5c83bf7308e.tar.gz
gentoo-2-3e8d89356c572fc379157743e46bf5c83bf7308e.tar.bz2
gentoo-2-3e8d89356c572fc379157743e46bf5c83bf7308e.zip
Version bump.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qtscrobbler/ChangeLog10
-rw-r--r--media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch46
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.10.ebuild65
3 files changed, 119 insertions, 2 deletions
diff --git a/media-sound/qtscrobbler/ChangeLog b/media-sound/qtscrobbler/ChangeLog
index 05f190dbb8e0..982357e4ed58 100644
--- a/media-sound/qtscrobbler/ChangeLog
+++ b/media-sound/qtscrobbler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qtscrobbler
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/ChangeLog,v 1.5 2009/03/15 20:44:08 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/ChangeLog,v 1.6 2010/10/31 11:33:28 ssuominen Exp $
+
+*qtscrobbler-0.10 (31 Oct 2010)
+
+ 31 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +qtscrobbler-0.10.ebuild, +files/qtscrobbler-0.10-Makefile.patch:
+ Version bump.
15 Mar 2009; Markus Meier <maekke@gentoo.org> qtscrobbler-0.9.ebuild:
amd64/x86 stable, bug #262543
diff --git a/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
new file mode 100644
index 000000000000..0558b72c9bf5
--- /dev/null
+++ b/media-sound/qtscrobbler/files/qtscrobbler-0.10-Makefile.patch
@@ -0,0 +1,46 @@
+--- src/cli/Makefile
++++ src/cli/Makefile
+@@ -1,4 +1,4 @@
+-CC = g++
++CXX ?= g++
+ mingw = false
+ WINDRES =
+ RES =
+@@ -27,7 +27,7 @@
+ LINKOBJ = scrobble-cli.o libscrobble.o md5.o ConvertUTF.o mtp.o $(RES)
+ endif
+
+-CFLAGS = -Wall -O2 -g $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
++CXXFLAGS += -Wall $(INCLUDE) $(CURL_FLAGS) $(MTP_FLAGS)
+
+ .PHONY: all all-before all-after clean clean-custom
+
+@@ -37,22 +37,22 @@
+ rm -f *.o *~ *.d $(BIN) $(BIN).exe
+
+ $(BIN): $(OBJ)
+- $(CC) $(LINKOBJ) -o $(BIN) $(LIBS)
++ $(CXX) $(LDFLAGS) $(LINKOBJ) -o $(BIN) $(LIBS)
+
+ scrobble-cli.o: scrobble-cli.cpp
+- $(CC) -c scrobble-cli.cpp -o scrobble-cli.o $(CFLAGS)
++ $(CXX) -c scrobble-cli.cpp -o scrobble-cli.o $(CXXFLAGS)
+
+ libscrobble.o: ../lib/libscrobble.cpp
+- $(CC) -c ../lib/libscrobble.cpp -o libscrobble.o $(CFLAGS)
++ $(CXX) -c ../lib/libscrobble.cpp -o libscrobble.o $(CXXFLAGS)
+
+ md5.o: ../lib/md5.c
+- $(CC) -c ../lib/md5.c -o md5.o $(CFLAGS)
++ $(CXX) -c ../lib/md5.c -o md5.o $(CXXFLAGS)
+
+ ConvertUTF.o: ../lib/ConvertUTF.c
+- $(CC) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CFLAGS)
++ $(CXX) -c ../lib/ConvertUTF.c -o ConvertUTF.o $(CXXFLAGS)
+
+ mtp.o: ../lib/mtp-libmtp.cpp
+- $(CC) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CFLAGS)
++ $(CXX) -c ../lib/mtp-libmtp.cpp -o mtp.o $(CXXFLAGS)
+
+ install:
+ install -D -m 755 scrobble-cli -p $(DESTDIR)$(bindir)/scrobble-cli
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild
new file mode 100644
index 000000000000..2d559ba63795
--- /dev/null
+++ b/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.10.ebuild,v 1.1 2010/10/31 11:33:28 ssuominen Exp $
+
+EAPI=2
+inherit eutils qt4-r2 toolchain-funcs
+
+MY_PN=qtscrob
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Updates a last.fm profile using information from a supported portable music player"
+HOMEPAGE="http://qtscrob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli +qt4"
+
+RDEPEND="media-libs/libmtp
+ net-misc/curl
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_configure() {
+ if use qt4; then
+ pushd src/qt >/dev/null
+ eqmake4 ${MY_PN}.pro
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ if use cli; then
+ tc-export CXX
+ emake -C src/cli || die
+ fi
+
+ if use qt4; then
+ emake -C src/qt || die
+ fi
+}
+
+src_install() {
+ if use cli; then
+ newbin src/cli/scrobble-cli qtscrobbler-cli || die
+ fi
+
+ if use qt4; then
+ pushd src/qt >/dev/null
+ newbin qtscrob qtscrobbler
+ newicon resources/icons/128.png qtscrobbler.png
+ make_desktop_entry qtscrobbler QtScrobbler
+ popd >/dev/null
+ fi
+
+ dodoc AUTHORS CHANGELOG README
+}