summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-21 00:30:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-21 00:30:33 +0000
commit472f3e46ee3ef988917d02c5eca0a0df99979ddd (patch)
treecec932594a7dae9c2a29452df7f338ae42ee9a64 /media-sound
parentFixed download URL (silent upstream repackaging). (diff)
downloadgentoo-2-472f3e46ee3ef988917d02c5eca0a0df99979ddd.tar.gz
gentoo-2-472f3e46ee3ef988917d02c5eca0a0df99979ddd.tar.bz2
gentoo-2-472f3e46ee3ef988917d02c5eca0a0df99979ddd.zip
Version bump and new init script to use the new system-wide mode (compatible with our 0.9.2).
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog9
-rw-r--r--media-sound/pulseaudio/files/digest-pulseaudio-0.9.33
-rw-r--r--media-sound/pulseaudio/files/pulseaudio.init.d-221
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.3.ebuild108
4 files changed, 140 insertions, 1 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 30847a7bc246..e83803ee0bab 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.12 2006/07/19 11:58:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.13 2006/07/21 00:30:33 flameeyes Exp $
+
+*pulseaudio-0.9.3 (21 Jul 2006)
+
+ 21 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pulseaudio.init.d-2, +pulseaudio-0.9.3.ebuild:
+ Version bump and new init script to use the new system-wide mode (compatible
+ with our 0.9.2).
19 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
files/pulseaudio.init.d, pulseaudio-0.9.2.ebuild:
diff --git a/media-sound/pulseaudio/files/digest-pulseaudio-0.9.3 b/media-sound/pulseaudio/files/digest-pulseaudio-0.9.3
new file mode 100644
index 000000000000..083d602152a0
--- /dev/null
+++ b/media-sound/pulseaudio/files/digest-pulseaudio-0.9.3
@@ -0,0 +1,3 @@
+MD5 65da3e44e0580425dae628f7e39149cb pulseaudio-0.9.3.tar.gz 1111287
+RMD160 88ce7f6f55a4ece7620d148912bc6efed8c807f6 pulseaudio-0.9.3.tar.gz 1111287
+SHA256 f07bd02e1769485c72bd299e4eb28f9eb29a96fb943267e26e49b6ba34d377fc pulseaudio-0.9.3.tar.gz 1111287
diff --git a/media-sound/pulseaudio/files/pulseaudio.init.d-2 b/media-sound/pulseaudio/files/pulseaudio.init.d-2
new file mode 100644
index 000000000000..8db38990b55e
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio.init.d-2
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+
+depend() {
+ use net@extradepend@
+}
+
+start() {
+ ebegin "Starting pulseaudio"
+ PA_ALL_OPTS="${PA_OPTS} --fail=1 --daemonize=1 --system"
+ start-stop-daemon --start --exec /usr/bin/pulseaudio -- ${PA_ALL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pulseaudio"
+ start-stop-daemon --stop --quiet --exec /usr/bin/pulseaudio
+ eend $?
+}
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.3.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.3.ebuild
new file mode 100644
index 000000000000..273a33801b4c
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-0.9.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.3.ebuild,v 1.1 2006/07/21 00:30:33 flameeyes Exp $
+
+inherit eutils libtool # autotools
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://0pointer.de/lennart/projects/pulseaudio/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+IUSE="alsa avahi caps jack lirc oss tcpd X"
+
+RDEPEND="X? ( || ( x11-libs/libX11 <virtual/x11-7 ) )
+ caps? ( sys-libs/libcap )
+ >=media-libs/audiofile-0.2.6-r1
+ >=media-libs/libsamplerate-0.1.1-r1
+ >=media-libs/libsndfile-1.0.10
+ >=dev-libs/liboil-0.3.6
+ alsa? ( >=media-libs/alsa-lib-1.0.10 )
+ >=dev-libs/glib-2.4.0
+ avahi? ( net-dns/avahi )
+ >=dev-libs/liboil-0.3.0
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ app-admin/eselect-esd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-dns/avahi dbus ; then
+ echo
+ eerror "In order to compile pulseaudio with avahi support, you need to have"
+ eerror "net-dns/avahi emerged with 'dbus' in your USE flag. Please add that"
+ eerror "flag, re-emerge avahi, and then emerge pulseaudio again."
+ die "net-dns/avahi is missing the D-Bus bindings."
+ fi
+
+ enewgroup audio 18 # Just make sure it exists
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.9.2-esdcompat.patch"
+
+ # eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --enable-largefile \
+ --enable-glib2 \
+ --disable-solaris \
+ --disable-asyncns \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable lirc) \
+ $(use_enable avahi) \
+ $(use_with caps) \
+ $(use_with X x) \
+ --disable-ltdl-install \
+ --localstatedir=/var \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local extradepend
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+ use alsa && extradepend="$extradepend alsasound"
+ use avahi && extradepend="$extradepend avahi"
+ sed -e "s/@extradepend@/$extradepend/" "${FILESDIR}/pulseaudio.init.d-2" > "${T}/pulseaudio"
+ doinitd "${T}/pulseaudio"
+
+ dohtml -r doc
+ dodoc README doc/todo
+}
+
+pkg_postinst() {
+ elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+ elog "This support is enabled by starting the pulsedaemon init.d ."
+ elog "To be able to access that you need to be in the group pulse-access."
+ elog "For more information about system-wide support, please refer to"
+ elog " http://pulseaudio.org/wiki/SystemWideInstance"
+
+ elog "To use the ESounD wrapper while using a system-wide daemon, you also"
+ elog "need to enable auth-anonymous for the esound-unix module, or to copy"
+ elog "/var/run/pulse/.esdcookie into each home directory."
+
+ eselect esd update --if-unset
+}