summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-05 20:50:23 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-05 20:50:23 +0000
commit73dc9794ff9378d2954318deaec31681b46e87b2 (patch)
tree816163213e8f133bcfe0f3acf1a4b19470598d05 /media-sound
parentvBump to 0.6, closes bug #154486 (diff)
downloadgentoo-2-73dc9794ff9378d2954318deaec31681b46e87b2.tar.gz
gentoo-2-73dc9794ff9378d2954318deaec31681b46e87b2.tar.bz2
gentoo-2-73dc9794ff9378d2954318deaec31681b46e87b2.zip
Add fix for --as-needed; bug #168427
(Portage version: 2.1.2.1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.9.8-as-needed.patch22
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.8.ebuild4
3 files changed, 30 insertions, 2 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 22e09bd010c1..b790b2753335 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.90 2007/03/05 20:10:02 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.91 2007/03/05 20:50:23 dang Exp $
+
+ 05 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/rhythmbox-0.9.8-as-needed.patch, rhythmbox-0.9.8.ebuild:
+ Add fix for --as-needed; bug #168427
05 Mar 2007; Daniel Gryniewicz <dang@gentoo.org>
+files/rhythmbox-0.9.8-multijob-fix.patch, rhythmbox-0.9.8.ebuild:
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.9.8-as-needed.patch b/media-sound/rhythmbox/files/rhythmbox-0.9.8-as-needed.patch
new file mode 100644
index 000000000000..7622ad7b0930
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.9.8-as-needed.patch
@@ -0,0 +1,22 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN rhythmbox-0.9.8.orig/widgets/Makefile.am rhythmbox-0.9.8/widgets/Makefile.am
+--- rhythmbox-0.9.8.orig/widgets/Makefile.am 2007-01-09 01:42:22.000000000 -0500
++++ rhythmbox-0.9.8/widgets/Makefile.am 2007-03-05 15:32:20.000000000 -0500
+@@ -63,5 +63,5 @@ INCLUDES = \
+ $(RHYTHMBOX_CFLAGS)
+
+ librbwidgets_la_LDFLAGS = -export-dynamic
+-librbwidgets_la_LIBADD = $(LIBSEXY_LIBS)
++librbwidgets_la_LIBADD = $(NOTIFY_LIBS) $(LIBSEXY_LIBS)
+
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN rhythmbox-0.9.8.orig/widgets/Makefile.in rhythmbox-0.9.8/widgets/Makefile.in
+--- rhythmbox-0.9.8.orig/widgets/Makefile.in 2007-02-21 04:52:25.000000000 -0500
++++ rhythmbox-0.9.8/widgets/Makefile.in 2007-03-05 15:32:34.000000000 -0500
+@@ -373,7 +373,7 @@ INCLUDES = \
+
+
+ librbwidgets_la_LDFLAGS = -export-dynamic
+-librbwidgets_la_LIBADD = $(LIBSEXY_LIBS)
++librbwidgets_la_LIBADD = $(NOTIFY_LIBS) $(LIBSEXY_LIBS)
+ subdir = widgets
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild
index d8c24193e2f0..845dfddb11b3 100644
--- a/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild,v 1.3 2007/03/05 20:10:02 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.8.ebuild,v 1.4 2007/03/05 20:50:23 dang Exp $
inherit gnome2 eutils
@@ -102,6 +102,8 @@ src_unpack() {
gnome2_src_unpack
# Fix parallel build; bug #169182
epatch "${FILESDIR}"/${P}-multijob-fix.patch
+ # Fix --as-needed build. Bug #168427
+ epatch "${FILESDIR}"/${P}-as-needed.patch
}
src_compile() {