summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-18 12:29:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-18 12:29:14 +0000
commit7909b5c1bdacc6897b07076d5541aa58999d7ee9 (patch)
tree15636c1ceeb72dd2b66d7e6b50522c12ea76ae40 /media-sound
parentremove old (diff)
downloadgentoo-2-7909b5c1bdacc6897b07076d5541aa58999d7ee9.tar.gz
gentoo-2-7909b5c1bdacc6897b07076d5541aa58999d7ee9.tar.bz2
gentoo-2-7909b5c1bdacc6897b07076d5541aa58999d7ee9.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.11.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 622e629d108c..528b949516bc 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.80 2014/01/18 12:26:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.81 2014/01/18 12:29:14 aballier Exp $
+
+*qjackctl-0.3.11 (18 Jan 2014)
+
+ 18 Jan 2014; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.11.ebuild:
+ version bump
18 Jan 2014; Alexis Ballier <aballier@gentoo.org> -qjackctl-0.3.8.ebuild,
-qjackctl-0.3.9.ebuild:
diff --git a/media-sound/qjackctl/qjackctl-0.3.11.ebuild b/media-sound/qjackctl/qjackctl-0.3.11.ebuild
new file mode 100644
index 000000000000..ba2ba78ef4a6
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.11.ebuild,v 1.1 2014/01/18 12:29:14 aballier Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:4 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
+
+PATCHES=( "${FILESDIR}/${PN}-0.3.9-gcc47.patch" )
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+ lupdate ${PN}.pro || die "lupdate failed"
+}