summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-28 06:58:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-28 06:58:25 +0000
commit7a59154ed8fde5187090dd9001216ea3d8139542 (patch)
tree0870459d0d36cc8c787cd29e4612027dc7c318ca /media-sound
parentBump -5.7 development version (diff)
downloadgentoo-2-7a59154ed8fde5187090dd9001216ea3d8139542.tar.gz
gentoo-2-7a59154ed8fde5187090dd9001216ea3d8139542.tar.bz2
gentoo-2-7a59154ed8fde5187090dd9001216ea3d8139542.zip
version bump by Andrea Pinazzi <follettoonip@gmail.com>, bug #240738, and convert to EAPI-2 for usedeps
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.3 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/exaile/ChangeLog8
-rw-r--r--media-sound/exaile/exaile-0.2.14.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 637f5e37911b..012081e323a2 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.45 2008/05/29 17:15:05 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.46 2008/10/28 06:58:25 aballier Exp $
+
+*exaile-0.2.14 (28 Oct 2008)
+
+ 28 Oct 2008; Alexis Ballier <aballier@gentoo.org> +exaile-0.2.14.ebuild:
+ version bump by Andrea Pinazzi <follettoonip@gmail.com>, bug #240738, and
+ convert to EAPI-2 for usedeps
29 May 2008; Ali Polatel <hawking@gentoo.org> exaile-0.2.13.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/media-sound/exaile/exaile-0.2.14.ebuild b/media-sound/exaile/exaile-0.2.14.ebuild
new file mode 100644
index 000000000000..5b99953c092f
--- /dev/null
+++ b/media-sound/exaile/exaile-0.2.14.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.14.ebuild,v 1.1 2008/10/28 06:58:25 aballier Exp $
+
+EAPI=2
+
+inherit eutils fdo-mime multilib python
+
+GVER=0.10
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org"
+SRC_URI="http://www.exaile.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac alsa cdparanoia equalizer flac gnome ipod +jpeg libnotify +libsexy
+ mad musepack nls ogg oss +png vorbis"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.12
+ >=dev-python/pygtk-2.10
+ || ( >=dev-lang/python-2.5[sqlite] >=dev-python/pysqlite-2.3.5 )
+ || ( >=dev-lang/python-2.5 dev-python/elementtree )
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ gnome? ( >=dev-python/gnome-python-extras-2.14
+ >=media-plugins/gst-plugins-gconf-${GVER}
+ >=media-plugins/gst-plugins-gnomevfs-${GVER} )
+ >=media-libs/gst-plugins-good-${GVER}
+ equalizer? ( >=media-libs/gst-plugins-bad-0.10.5 )
+ >=dev-python/gst-python-0.10.9
+ musepack? ( >=media-plugins/gst-plugins-musepack-${GVER} )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-${GVER} )
+ flac? ( >=media-plugins/gst-plugins-flac-${GVER} )
+ aac? ( >=media-plugins/gst-plugins-faad-${GVER} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${GVER} )
+ oss? ( >=media-plugins/gst-plugins-oss-${GVER} )
+ mad? ( >=media-plugins/gst-plugins-mad-${GVER} )
+ ogg? ( >=media-plugins/gst-plugins-ogg-${GVER} )
+ cdparanoia? ( >=media-plugins/gst-plugins-cdparanoia-${GVER}
+ dev-python/cddb-py )
+ ipod? ( >=media-libs/libgpod-0.4[python]
+ >=media-plugins/gst-plugins-faad-${GVER} )
+ jpeg? ( >=media-plugins/gst-plugins-jpeg-${GVER} )
+ png? ( >=media-plugins/gst-plugins-libpng-${GVER} )"
+DEPEND="nls? ( dev-util/intltool sys-devel/gettext )"
+
+src_compile() {
+ emake mmkeys.so || die "emake mmkeys.so failed."
+
+ if use nls; then
+ emake translations || die "emake translations failed."
+ fi
+}
+
+src_install() {
+ emake PREFIX="/usr" LIBDIR="/$(get_libdir)" DESTDIR="${D}" install || die "emake install failed."
+ newdoc changelog ChangeLog
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ elog "You need media-plugins/gst-plugins-gnomevfs for streaming, but you may also try"
+ elog "media-plugins/gst-plugins-neon to avoid installing gnome."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}