summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-19 14:24:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-19 14:24:39 +0000
commit840a06d1337fa420a2e3f7c5c7112ac3eae87400 (patch)
treec04f1a9c7350bb06a89b251d2124b37c9ca5dd31 /media-sound
parentalpha/ia64/s390/sh/sparc stable wrt #394393 (diff)
downloadgentoo-2-840a06d1337fa420a2e3f7c5c7112ac3eae87400.tar.gz
gentoo-2-840a06d1337fa420a2e3f7c5c7112ac3eae87400.tar.bz2
gentoo-2-840a06d1337fa420a2e3f7c5c7112ac3eae87400.zip
version bump
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpc/ChangeLog7
-rw-r--r--media-sound/mpc/mpc-0.22.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/media-sound/mpc/ChangeLog b/media-sound/mpc/ChangeLog
index cf2248c98339..411092b4db4b 100644
--- a/media-sound/mpc/ChangeLog
+++ b/media-sound/mpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/ChangeLog,v 1.91 2012/01/16 03:02:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/ChangeLog,v 1.92 2012/02/19 14:24:39 aballier Exp $
+
+*mpc-0.22 (19 Feb 2012)
+
+ 19 Feb 2012; Alexis Ballier <aballier@gentoo.org> +mpc-0.22.ebuild:
+ version bump
16 Jan 2012; Jeroen Roovers <jer@gentoo.org> mpc-0.21.ebuild:
Stable for HPPA (bug #397101).
diff --git a/media-sound/mpc/mpc-0.22.ebuild b/media-sound/mpc/mpc-0.22.ebuild
new file mode 100644
index 000000000000..45af2c85694a
--- /dev/null
+++ b/media-sound/mpc/mpc-0.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/mpc-0.22.ebuild,v 1.1 2012/02/19 14:24:39 aballier Exp $
+
+EAPI=4
+inherit bash-completion-r1
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="iconv"
+
+RDEPEND=">=media-libs/libmpdclient-2.2
+ iconv? ( virtual/libiconv )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS NEWS README doc/mpd-m3u-handler.sh doc/mppledit
+ doc/mpd-pls-handler.sh )
+
+src_configure() {
+ econf $(use_enable iconv) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ newbashcomp doc/mpc-completion.bash ${PN}
+}