summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-16 21:05:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-16 21:05:08 +0000
commita0d1cc53be8b87b6ba359a2417e5fce1f6fa25dc (patch)
tree4ecdc18b35182f5941b433e77d25383199daeb92 /media-sound
parentVersion bumped, Bug #190732. (diff)
downloadgentoo-2-a0d1cc53be8b87b6ba359a2417e5fce1f6fa25dc.tar.gz
gentoo-2-a0d1cc53be8b87b6ba359a2417e5fce1f6fa25dc.tar.bz2
gentoo-2-a0d1cc53be8b87b6ba359a2417e5fce1f6fa25dc.zip
fix build with libtool 2.2
(Portage version: 2.1.5)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/linuxsampler/ChangeLog6
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch20
-rw-r--r--media-sound/linuxsampler/linuxsampler-0.5.1.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/media-sound/linuxsampler/ChangeLog b/media-sound/linuxsampler/ChangeLog
index 18bb19bc6e80..1332dccda759 100644
--- a/media-sound/linuxsampler/ChangeLog
+++ b/media-sound/linuxsampler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/linuxsampler
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.10 2008/01/27 10:35:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.11 2008/05/16 21:05:07 aballier Exp $
+
+ 16 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/linuxsampler-0.5.1-libtool22.patch, linuxsampler-0.5.1.ebuild:
+ fix build with libtool 2.2
27 Jan 2008; Alexis Ballier <aballier@gentoo.org>
-files/linuxsampler-0.3.3-gcc4.patch, -linuxsampler-0.3.3.ebuild,
diff --git a/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch b/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch
new file mode 100644
index 000000000000..3c4add20637f
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-0.5.1-libtool22.patch
@@ -0,0 +1,20 @@
+Index: linuxsampler-0.5.1/configure.in
+===================================================================
+--- linuxsampler-0.5.1.orig/configure.in
++++ linuxsampler-0.5.1/configure.in
+@@ -38,6 +38,7 @@ LSCP_RELEASE_MINOR=3
+ AC_DEFINE_UNQUOTED(LSCP_RELEASE_MAJOR, ${LSCP_RELEASE_MAJOR}, [LSCP spec major version this release complies with.])
+ AC_DEFINE_UNQUOTED(LSCP_RELEASE_MINOR, ${LSCP_RELEASE_MINOR}, [LSCP spec minor version this release complies with.])
+
++AC_PROG_CXX
+ AM_PROG_LIBTOOL
+
+ AC_SUBST(SHLIB_VERSION_ARG)
+@@ -1082,7 +1083,6 @@ AM_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(linuxsampler, "$LINUXSAMPLER_RELEASE_MAJOR.$LINUXSAMPLER_RELEASE_MINOR.$LINUXSAMPLER_RELEASE_BUILD")
+
+ AC_LANG_CPLUSPLUS
+-AC_PROG_CXX
+
+ # some gcc 4.0 versions need -msse for SSE register allocations
+ if test "$config_asm" = "yes"; then
diff --git a/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
index c5d918171066..4f500aff674b 100644
--- a/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
+++ b/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild,v 1.1 2008/01/12 10:36:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.5.1.ebuild,v 1.2 2008/05/16 21:05:07 aballier Exp $
inherit autotools eutils
@@ -26,6 +26,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-pkgconfiginit.patch"
+ epatch "${FILESDIR}/${P}-libtool22.patch"
AT_M4DIR="m4" eautoreconf
}