summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-28 20:19:01 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-28 20:19:01 +0000
commita3b6d5a2228bbd288c68f89afe40054fd2d434dc (patch)
treef6d44f323a01ee2f0a86fa76b8a73fe77a218cf1 /media-sound
parentVersion bump. Added ~sparc. (Manifest recommit) (diff)
downloadgentoo-2-a3b6d5a2228bbd288c68f89afe40054fd2d434dc.tar.gz
gentoo-2-a3b6d5a2228bbd288c68f89afe40054fd2d434dc.tar.bz2
gentoo-2-a3b6d5a2228bbd288c68f89afe40054fd2d434dc.zip
static USE flag support. Now using DESTDIR.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fluidsynth/ChangeLog4
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.5.ebuild14
2 files changed, 9 insertions, 9 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index e99b16f544bf..f8f701fc242a 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,12 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.16 2004/09/28 20:15:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.17 2004/09/28 20:19:01 eradicator Exp $
*fluidsynth-1.0.5 (28 Sep 2004)
28 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+fluidsynth-1.0.5.ebuild:
- Version bump. Added ~sparc.
+ Version bump. Added ~sparc. static USE flag support. Now using DESTDIR.
03 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
fluidsynth-1.0.3.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild
index 95bb79193861..6f739b2eabe7 100644
--- a/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild,v 1.1 2004/09/28 20:15:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.5.ebuild,v 1.2 2004/09/28 20:19:01 eradicator Exp $
-IUSE="alsa jack sse ladcca"
+IUSE="alsa jack sse ladcca static"
inherit flag-o-matic eutils
@@ -30,13 +30,14 @@ asrc_unpack() {
src_compile() {
local myconf
- myconf="--enable-ladspa"
+ myconf="--enable-ladspa `use_enable jack jack-support` `use_enable static`"
+
if use alsa; then
myconf="${myconf} --enable-alsa `use_enable ladcca`"
else
myconf="${myconf} --disable-alsa --disable-ladcca"
fi
- use jack || myconf="--disable-jack-support ${myconf}"
+
if use sse; then
myconf="--enable-SSE ${myconf}"
# If your CFLAGS include optimizations for sse, ie:
@@ -48,13 +49,12 @@ src_compile() {
filter-flags "-mfpmath=sse"
fi
fi
+
econf ${myconf} || die "./configure failed"
emake || die
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS COPYING INSTALL NEWS README THANKS TODO
}
-
-