summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-01 08:22:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-01 08:22:28 +0000
commitafb8c1695e0a593ba25cd475c90b31c776a77297 (patch)
tree4e7fc04c309f723de413b2c12c88bc817ed99076 /media-sound
parentFixed allignment.patch part II (diff)
downloadgentoo-2-afb8c1695e0a593ba25cd475c90b31c776a77297.tar.gz
gentoo-2-afb8c1695e0a593ba25cd475c90b31c776a77297.tar.bz2
gentoo-2-afb8c1695e0a593ba25cd475c90b31c776a77297.zip
Revbump. Build system requires python2. pyrex became a build time
depend, moved to EAPI=3. Disabled building of bundled faad2, use only external one. (Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms2/ChangeLog11
-rw-r--r--media-sound/xmms2/xmms2-0.7-r2.ebuild (renamed from media-sound/xmms2/xmms2-0.7-r1.ebuild)21
2 files changed, 24 insertions, 8 deletions
diff --git a/media-sound/xmms2/ChangeLog b/media-sound/xmms2/ChangeLog
index 6dc265d781f4..423b94795a9b 100644
--- a/media-sound/xmms2/ChangeLog
+++ b/media-sound/xmms2/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/xmms2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.2 2010/06/30 17:20:13 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.3 2010/07/01 08:22:28 slyfox Exp $
+
+*xmms2-0.7-r2 (01 Jul 2010)
+
+ 01 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> -xmms2-0.7-r1.ebuild,
+ +xmms2-0.7-r2.ebuild:
+ Revision bump. Building xmms2 requires python2, pyrex became a build time
+ depend, moved to EAPI=3. Thanks to arfrever.
+ Disabled building of bundled faad2, use only external one.
+ Thanks to ssuominen.
*xmms2-0.7-r1 (30 Jun 2010)
diff --git a/media-sound/xmms2/xmms2-0.7-r1.ebuild b/media-sound/xmms2/xmms2-0.7-r2.ebuild
index 7bf76110bb37..01af53c4c21e 100644
--- a/media-sound/xmms2/xmms2-0.7-r1.ebuild
+++ b/media-sound/xmms2/xmms2-0.7-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.7-r1.ebuild,v 1.1 2010/06/30 17:20:13 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.7-r2.ebuild,v 1.1 2010/07/01 08:22:28 slyfox Exp $
+
+EAPI=3
-EAPI=2
inherit base eutils python
MY_P="${P}DrNo"
@@ -62,11 +63,12 @@ RDEPEND="server? (
cxx? ( >=dev-libs/boost-1.32 )
mlib-update? ( app-admin/gamin )
perl? ( >=dev-lang/perl-5.8.8 )
- python? ( >=dev-python/pyrex-0.9.5.1 )
+ python? ( =dev-lang/python-2* )
ruby? ( >=dev-lang/ruby-1.8.5 ) "
DEPEND="${RDEPEND}
- >=dev-lang/python-2.4.3"
+ =dev-lang/python-2*
+ python? ( dev-python/pyrex )"
S="${WORKDIR}/${MY_P}"
@@ -93,6 +95,11 @@ xmms2_flag() {
esac
}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_configure() {
# ./configure alike options.
local waf_params="--prefix=/usr \
@@ -162,7 +169,7 @@ src_configure() {
" mac"
" mms"
" mad"
- "aac mp4"
+ "DISABLED mp4" # uses bundled patched faad2
"mp3 mpg123"
" modplug"
" musepack"
@@ -233,9 +240,9 @@ pkg_postinst() {
einfo "Disable the phonehome useflag if you don't like that"
fi
- use python && python_mod_optimize "$(python_get_sitedir)/xmmsclient"
+ use python && python_mod_optimize xmmsclient
}
pkg_postrm() {
- use python && python_mod_cleanup "$(python_get_sitedir)/xmmsclient"
+ use python && python_mod_cleanup xmmsclient
}