summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-09 18:44:21 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-09 18:44:21 +0000
commitb55de124f436ff016a05e2ab62f3afb95ba253ee (patch)
treeec6878046400152a78ed6128eb47e81ff1f981cb /media-sound
parentpython-otr removed, no longer needed as gajim provides plugin (diff)
downloadgentoo-2-b55de124f436ff016a05e2ab62f3afb95ba253ee.tar.gz
gentoo-2-b55de124f436ff016a05e2ab62f3afb95ba253ee.tar.bz2
gentoo-2-b55de124f436ff016a05e2ab62f3afb95ba253ee.zip
Version bump to 3.0.11.1; fixes bug #490570, reported by Stephan Kupfer and pierigno.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/teamspeak-client-bin/ChangeLog9
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.13.1.ebuild74
2 files changed, 82 insertions, 1 deletions
diff --git a/media-sound/teamspeak-client-bin/ChangeLog b/media-sound/teamspeak-client-bin/ChangeLog
index f120646383c8..993f41d849c7 100644
--- a/media-sound/teamspeak-client-bin/ChangeLog
+++ b/media-sound/teamspeak-client-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/teamspeak-client-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.35 2013/10/12 12:35:30 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.36 2013/11/09 18:44:21 tomwij Exp $
+
+*teamspeak-client-bin-3.0.13.1 (09 Nov 2013)
+
+ 09 Nov 2013; Tom Wijsman <TomWij@gentoo.org>
+ +teamspeak-client-bin-3.0.13.1.ebuild:
+ Version bump to 3.0.11.1; fixes bug #490570, reported by Stephan Kupfer and
+ pierigno.
*teamspeak-client-bin-3.0.13 (12 Oct 2013)
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.13.1.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.13.1.ebuild
new file mode 100644
index 000000000000..b893990eb91e
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.13.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.13.1.ebuild,v 1.1 2013/11/09 18:44:21 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils unpacker
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="http://www.teamspeak.com/"
+LICENSE="teamspeak3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch mirror strip"
+IUSE="alsa pulseaudio"
+
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+SRC_URI="amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4[accessibility,xinerama]
+ dev-qt/qtsql:4
+ sys-libs/glibc
+ sys-libs/zlib
+
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ if use amd64 ; then
+ einfo "Please download TeamSpeak3-Client-linux_amd64-${PV/_/-}.run"
+ elif use x86 ; then
+ einfo "Please download TeamSpeak3-Client-linux_x86-${PV/_/-}.run"
+ fi
+ einfo "from ${HOMEPAGE}?page=downloads and place this"
+ einfo "file in ${DISTDIR}"
+}
+
+src_prepare() {
+ # Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807.
+ rm libQt* || die "Couldn't remove bundled Qt libraries."
+
+ # Remove unwanted soundbackends.
+ if ! use alsa ; then
+ rm soundbackends/libalsa* || die
+ fi
+
+ if ! use pulseaudio ; then
+ rm soundbackends/libpulseaudio* || die
+ fi
+
+ # Rename the tsclient to its shorter version, required by the teamspeak3 script we install.
+ mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version."
+}
+
+src_install() {
+ dodir /opt/teamspeak3-client
+ insinto /opt/teamspeak3-client
+ doins -r *
+
+ fperms +x /opt/teamspeak3-client/ts3client
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/teamspeak3"
+
+ make_desktop_entry teamspeak3 TeamSpeak3 \
+ "/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \
+ Network
+}