summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-27 10:21:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-27 10:21:03 +0000
commitba455ee693d6e0680fd290ab21939f7e112c9208 (patch)
tree700b47be4962fadcd4334509d713e7f7ece58c3a /media-sound
parentMoved mask to all 1.3_beta version for amarok. (diff)
downloadgentoo-2-ba455ee693d6e0680fd290ab21939f7e112c9208.tar.gz
gentoo-2-ba455ee693d6e0680fd290ab21939f7e112c9208.tar.bz2
gentoo-2-ba455ee693d6e0680fd290ab21939f7e112c9208.zip
New upstream beta.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/Manifest4
-rw-r--r--media-sound/amarok/amarok-1.3_beta2.ebuild78
-rw-r--r--media-sound/amarok/files/digest-amarok-1.3_beta21
4 files changed, 89 insertions, 2 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index ba5d024694a2..e010b1d927c7 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.58 2005/06/22 17:46:04 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.59 2005/06/27 10:21:02 flameeyes Exp $
+
+*amarok-1.3_beta2 (27 Jun 2005)
+
+ 27 Jun 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +amarok-1.3_beta2.ebuild:
+ New upstream beta.
22 Jun 2005; Hanno Boeck <hanno@gentoo.org> +files/amarok-gcc4.gz,
amarok-1.2.4.ebuild:
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index f75a51fedfdf..98196d8f25fb 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,9 +1,11 @@
MD5 f63eec35b59efad13dbd12ff72630731 ChangeLog 8828
-MD5 b23600108f12c98a4fd574d3487ee598 metadata.xml 175
MD5 88b8d4c17bbbc286e9080ea98c366fb1 amarok-1.2.3.ebuild 2338
+MD5 b23600108f12c98a4fd574d3487ee598 metadata.xml 175
MD5 ddfc3b690c68a0ef88de6404675f3f94 amarok-1.2.4.ebuild 2409
MD5 7a18e71953e53d1f6c6e88cf107f4981 amarok-1.3_beta1.ebuild 2628
+MD5 7a18e71953e53d1f6c6e88cf107f4981 amarok-1.3_beta2.ebuild 2628
MD5 55c15fa0003bd71db5f7e23d750c0b16 files/digest-amarok-1.2.3 66
MD5 9966964d087dd7c05b7fa2efeff9b1ac files/digest-amarok-1.2.4 66
MD5 33dc3bd54b4b930141bae88dd6b51bb7 files/digest-amarok-1.3_beta1 70
MD5 32030194ea3f2079d1db17aa160f63a2 files/amarok-gcc4.gz 522
+MD5 95e269be8072f18e8c81a8f7c0036c52 files/digest-amarok-1.3_beta2 70
diff --git a/media-sound/amarok/amarok-1.3_beta2.ebuild b/media-sound/amarok/amarok-1.3_beta2.ebuild
new file mode 100644
index 000000000000..f32a9409e896
--- /dev/null
+++ b/media-sound/amarok/amarok-1.3_beta2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3_beta2.ebuild,v 1.1 2005/06/27 10:21:03 flameeyes Exp $
+
+inherit kde eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="amaroK - the audio player for KDE."
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="arts flac gstreamer kde mp3 mysql noamazon opengl postgres xine xmms visualization vorbis"
+# kde: enables compilation of the konqueror sidebar plugin
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( ( kde-base/kdemultimedia-arts kde-base/akode )
+ kde-base/kdemultimedia ) )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ gstreamer? ( >=media-libs/gstreamer-0.8.8 )
+ >=media-libs/tunepimp-0.3.0
+ >=media-libs/taglib-1.3.1
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ >=media-plugins/libvisual-plugins-0.2 )"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( >=media-plugins/gst-plugins-mad-0.8.6 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.8.6
+ >=media-plugins/gst-plugins-vorbis-0.8.6 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.8.6 ) )"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.3
+
+pkg_setup() {
+ if use arts && ! use xine && ! use gstreamer; then
+ ewarn "aRts support is deprecated, if you have problems please consider"
+ ewarn "enabling support for Xine or GStreamer"
+ ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
+ ebeep 2
+ fi
+
+ if ! use arts && ! use xine && ! use gstreamer; then
+ eerror "amaroK needs either aRts (deprecated), Xine or GStreamer to work,"
+ eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
+ die
+ fi
+
+ # check whether kdelibs was compiled with arts support
+ kde_pkg_setup
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="`kde-config --prefix`"
+
+ local myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer)
+ $(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)"
+
+ kde_src_compile
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.3_beta2 b/media-sound/amarok/files/digest-amarok-1.3_beta2
new file mode 100644
index 000000000000..76667944e45b
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.3_beta2
@@ -0,0 +1 @@
+MD5 ca7b22074dab6107c61b3b92dadbe26e amarok-1.3-beta2.tar.bz2 6636211