summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-08-21 01:20:16 +0000
committerMatt Turner <mattst88@gentoo.org>2011-08-21 01:20:16 +0000
commitc9720cecb325de2b06f378fc04b0cd435e900cd2 (patch)
treeacda1bd52400f8e675ac45f7d8764b42eeac8063 /media-sound
parentVersion bump (diff)
downloadgentoo-2-c9720cecb325de2b06f378fc04b0cd435e900cd2.tar.gz
gentoo-2-c9720cecb325de2b06f378fc04b0cd435e900cd2.tar.bz2
gentoo-2-c9720cecb325de2b06f378fc04b0cd435e900cd2.zip
Check for -lm, since it wasn't added to LIBS. Run autoreconf to generate aclocal.m4 without hardcoded LIBDIR=lib, bug 380027.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg321/ChangeLog11
-rw-r--r--media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch16
-rw-r--r--media-sound/mpg321/mpg321-0.2.12-r1.ebuild44
3 files changed, 69 insertions, 2 deletions
diff --git a/media-sound/mpg321/ChangeLog b/media-sound/mpg321/ChangeLog
index a3d8b3de6fbe..08376ec4fa50 100644
--- a/media-sound/mpg321/ChangeLog
+++ b/media-sound/mpg321/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/mpg321
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.74 2010/10/15 13:34:51 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.75 2011/08/21 01:20:16 mattst88 Exp $
+
+*mpg321-0.2.12-r1 (21 Aug 2011)
+
+ 21 Aug 2011; Matt Turner <mattst88@gentoo.org> +mpg321-0.2.12-r1.ebuild,
+ +files/mpg321-0.2.12-check-for-lround.patch:
+ Check for -lm, since it wasn't added to LIBS. Run autoreconf to generate
+ aclocal.m4 without hardcoded LIBDIR=lib, bug 380027.
15 Oct 2010; Brent Baude <ranger@gentoo.org> mpg321-0.2.12.ebuild:
stable ppc, bug 335565
diff --git a/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch b/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch
new file mode 100644
index 000000000000..ca52f7241167
--- /dev/null
+++ b/media-sound/mpg321/files/mpg321-0.2.12-check-for-lround.patch
@@ -0,0 +1,16 @@
+diff -ur mpg321-0.2.12-1.orig//configure.ac mpg321-0.2.12-1/configure.ac
+--- mpg321-0.2.12-1.orig//configure.ac 2010-07-03 07:46:40.000000000 -0400
++++ mpg321-0.2.12-1/configure.ac 2011-08-20 19:50:32.143229893 -0400
+@@ -75,6 +75,12 @@
+
+ AC_CHECK_FUNCS([gethostbyname memset munmap socket strchr strdup strerror strrchr strstr gettimeofday select getenv putenv setenv unsetenv strcasecmp])
+
++dnl Check if math library is needed.
++AC_CHECK_FUNC(lround)
++if test "$ac_cv_func_lround" = no; then
++ AC_CHECK_LIB(m, lround)
++fi
++
+ AC_ARG_ENABLE(mpg123_symlink,
+ [ --enable-mpg123-symlink Enable symlink of mpg123 to mpg321 [[default=yes]] ],
+ ,enable_mpg123_symlink=yes)
diff --git a/media-sound/mpg321/mpg321-0.2.12-r1.ebuild b/media-sound/mpg321/mpg321-0.2.12-r1.ebuild
new file mode 100644
index 000000000000..f9c4ff6dbc0d
--- /dev/null
+++ b/media-sound/mpg321/mpg321-0.2.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.12-r1.ebuild,v 1.1 2011/08/21 01:20:16 mattst88 Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P=${P}-1
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://mpg321.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="alsa ipv6"
+
+RDEPEND="sys-libs/zlib
+ media-libs/libmad
+ media-libs/libid3tag
+ media-libs/libao[alsa?]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-check-for-lround.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-mpg123-symlink \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newdoc debian/changelog ChangeLog.debian
+ dodoc AUTHORS BUGS HACKING NEWS README{,.remote} THANKS TODO
+}