summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-08-05 04:50:57 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-08-05 04:50:57 +0000
commite7c9fff7c247e3a15313beae26e97b45327392c0 (patch)
treeb089cd9d2f9293b7db5430dcb43791ce9af2b4a4 /media-sound
parentadded #1315; temp masked (diff)
downloadgentoo-2-e7c9fff7c247e3a15313beae26e97b45327392c0.tar.gz
gentoo-2-e7c9fff7c247e3a15313beae26e97b45327392c0.tar.bz2
gentoo-2-e7c9fff7c247e3a15313beae26e97b45327392c0.zip
Initial Release of ecasound.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ChangeLog16
-rw-r--r--media-sound/ecasound/ecasound-2.0.4.ebuild93
-rw-r--r--media-sound/ecasound/files/digest-ecasound-2.0.41
3 files changed, 110 insertions, 0 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
new file mode 100644
index 000000000000..031e16a7a2f8
--- /dev/null
+++ b/media-sound/ecasound/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for media-sound/ecasound-2.0.4.ebuild
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.1 2002/08/05 04:50:56 naz Exp $
+
+*ecasound-2.0.4.ebuild (04 Aug 2002)
+
+ 04 Aug 2002; Michael Nazaroff <naz@gentoo.org> ecasound-2.0.4.ebuild:
+
+ Added initial ChangeLog which should be updated whenever the package is updated in
+ any way. This changelog is targetted to users. This means that the comments should
+ well explained and written in clean English. The details about writing correct
+ changelogs are explained in the skel.ChangeLog file which you can find in the root
+ directory of the portage repository. Thanks to Jay Felice <jfelice@cronosys.com>
+ for the ebuild.
+
+
diff --git a/media-sound/ecasound/ecasound-2.0.4.ebuild b/media-sound/ecasound/ecasound-2.0.4.ebuild
new file mode 100644
index 000000000000..c56b76a385ae
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.0.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Nazaroff <naz@themoonsofjupiter.net>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A package for multitrack audio processing"
+SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
+HOMEPAGE="http://eca.cx/"
+LICENSE="GPL-2"
+
+SLOT="1"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ media-libs/ladspa-sdk
+ alsa? ( media-libs/alsa-lib )
+ oggvorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ audiofile? ( media-libs/audiofile )
+ libmikmod? ( media-libs/libmikmod )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )"
+
+# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
+# use flags for them.
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure 1
+ sed -e 's:map.h:map:g' 1 > configure
+
+}
+
+src_compile () {
+ local myconf
+
+ use alsa || myconf="$myconf --disable-alsa"
+ use arts || myconf="$myconf --disable-arts"
+ use ncurses || myconf="$myconf --disable-ncurses"
+ use audiofile || myconf="$myconf --disable-audiofile"
+ use oss || myconf="$myconf --disable-oss"
+
+ if use python; then
+ #
+ # ecasound is braindead about finding python includes/libdirs and
+ # about where to install modules. Luckily, it allows us to specify
+ # all this.
+ #
+ local python_version python_prefix python_includes python_modules
+ python_version="`python -c 'import sys; print sys.version[:3]'`"
+ python_prefix="`python -c 'import sys; print sys.prefix'`"
+
+ python_includes="$python_prefix/include/python$python_version"
+ python_modules="$python_prefix/lib/python$python_version"
+
+ # ecasound configure assumes `disable' if you pass
+ # --(enable|disable)-pyecasound. *sigh*
+ #myconf="$myconf --enable-pyecasound"
+
+ myconf="$myconf --with-python-includes=$python_includes"
+ myconf="$myconf --with-python-modules=$python_modules"
+ else
+ myconf="$myconf --disable-pyecasound"
+ fi
+
+ echo "configuring with ${myconf}"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use python; then
+ cd pyecasound || die
+ python -c "import compileall; compileall.compile_dir('.')" || die
+ python -O -c "import compileall; compileall.compile_dir('.')" || die
+ python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
+ install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
+ cd ..
+ fi
+
+ dodoc INSTALL FAQ BUGS COPYING NEWS README TODO
+ dodoc `find Documentation -name "*.html"`
+ dodoc Documentation/edi-list.txt
+}
diff --git a/media-sound/ecasound/files/digest-ecasound-2.0.4 b/media-sound/ecasound/files/digest-ecasound-2.0.4
new file mode 100644
index 000000000000..60202aa8fd74
--- /dev/null
+++ b/media-sound/ecasound/files/digest-ecasound-2.0.4
@@ -0,0 +1 @@
+MD5 73dfe024c541cea1a432510151fefbc8 ecasound-2.0.4.tar.gz 704638