summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-11 19:44:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-11 19:44:06 +0000
commitfd55d8beef4d7d5288a139ad35bc058539526710 (patch)
tree686b2511c1edd15a1ce76140f23c0041267ca425 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-fd55d8beef4d7d5288a139ad35bc058539526710.tar.gz
gentoo-2-fd55d8beef4d7d5288a139ad35bc058539526710.tar.bz2
gentoo-2-fd55d8beef4d7d5288a139ad35bc058539526710.zip
Version bump.
(Portage version: 2.1.2_rc3-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild84
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc13
3 files changed, 94 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 6010896ffdd8..eb46e57cd8fd 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.176 2006/11/08 01:27:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.177 2006/12/11 19:44:06 flameeyes Exp $
+
+*alsa-utils-1.0.14_rc1 (11 Dec 2006)
+
+ 11 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-utils-1.0.14_rc1.ebuild:
+ Version bump.
08 Nov 2006; Jeroen Roovers <jer@gentoo.org> alsa-utils-1.0.13.ebuild:
Stable for HPPA (bug #150540).
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild
new file mode 100644
index 000000000000..34cf5b4528b2
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.14_rc1.ebuild,v 1.1 2006/12/11 19:44:06 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+ newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1
new file mode 100644
index 000000000000..165051f70d6c
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.14_rc1
@@ -0,0 +1,3 @@
+MD5 931b22590a3a897d71c92fef6b1c1949 alsa-utils-1.0.14rc1.tar.bz2 980802
+RMD160 7d05cca060486d64e6ba87aa8c4a7e9b7a069ddb alsa-utils-1.0.14rc1.tar.bz2 980802
+SHA256 9b8ede92cfa5f28d6bf6bb1253bdc562f8ac937797fb5e5303609e2e49c2e886 alsa-utils-1.0.14rc1.tar.bz2 980802