summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
commit31305ba7754d135058f0700ff132c7ff29571f19 (patch)
tree20af4401a3b9594a69363be126108e203b51c32d /media-tv/gentoo-vdr-scripts
parentFix quoting, stop using ./configure (#120887) (diff)
downloadgentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.tar.gz
gentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.tar.bz2
gentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'media-tv/gentoo-vdr-scripts')
-rw-r--r--media-tv/gentoo-vdr-scripts/ChangeLog10
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild14
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild14
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild14
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild12
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild12
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild12
7 files changed, 66 insertions, 22 deletions
diff --git a/media-tv/gentoo-vdr-scripts/ChangeLog b/media-tv/gentoo-vdr-scripts/ChangeLog
index 8bef6f2958d6..d6ac157b98de 100644
--- a/media-tv/gentoo-vdr-scripts/ChangeLog
+++ b/media-tv/gentoo-vdr-scripts/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/gentoo-vdr-scripts
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/ChangeLog,v 1.94 2008/06/12 14:04:05 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/ChangeLog,v 1.95 2008/06/15 08:13:58 zmedico Exp $
+
+ 15 Jun 2008; Zac Medico <zmedico@gentoo.org>
+ gentoo-vdr-scripts-0.4.0.ebuild, gentoo-vdr-scripts-0.4.1.ebuild,
+ gentoo-vdr-scripts-0.4.2.ebuild, gentoo-vdr-scripts-0.4.3.ebuild,
+ gentoo-vdr-scripts-0.4.3-r1.ebuild, gentoo-vdr-scripts-0.4.4.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
12 Jun 2008; Matthias Schwarzott <zzam@gentoo.org>
gentoo-vdr-scripts-0.4.4.ebuild:
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
index aa542eea9ab8..d22dd4f6da29 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild,v 1.4 2007/10/04 12:28:10 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild,v 1.5 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -65,12 +65,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -95,7 +101,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild
index e1680a4b7e17..369eccff8d1e 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild,v 1.1 2007/10/04 14:56:28 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.1.ebuild,v 1.2 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -65,12 +65,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -95,7 +101,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
index 85cf5b78dfa6..fe595dd44065 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild,v 1.2 2007/12/11 23:16:07 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.2.ebuild,v 1.3 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -66,12 +66,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -96,7 +102,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild
index eff25650f25e..d4661ecd859d 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild,v 1.2 2008/04/19 12:26:21 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3-r1.ebuild,v 1.3 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -72,12 +72,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -102,7 +108,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild
index 5382c67de0f9..49bc5b8522c2 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild,v 1.2 2008/03/22 17:00:05 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.3.ebuild,v 1.3 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -66,12 +66,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -96,7 +102,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild
index 519b1a321277..63dc6c18c323 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild,v 1.2 2008/06/12 14:04:05 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.4.ebuild,v 1.3 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -66,12 +66,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -96,7 +102,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"