summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-03-17 11:19:33 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-03-17 11:19:33 +0000
commit08f3ef594a46584038906037aecd038171aafbb4 (patch)
tree0fd486b92f14e72eb3df536b26ef150372788107 /media-tv/linuxtv-dvb-apps
parentUnslot xulrunner (diff)
downloadgentoo-2-08f3ef594a46584038906037aecd038171aafbb4.tar.gz
gentoo-2-08f3ef594a46584038906037aecd038171aafbb4.tar.bz2
gentoo-2-08f3ef594a46584038906037aecd038171aafbb4.zip
Added new snapshot. This mainly adds new scan files.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-tv/linuxtv-dvb-apps')
-rw-r--r--media-tv/linuxtv-dvb-apps/ChangeLog8
-rw-r--r--media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20080317.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/media-tv/linuxtv-dvb-apps/ChangeLog b/media-tv/linuxtv-dvb-apps/ChangeLog
index 847c1dfe9c72..08983c0bdd77 100644
--- a/media-tv/linuxtv-dvb-apps/ChangeLog
+++ b/media-tv/linuxtv-dvb-apps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/linuxtv-dvb-apps
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.39 2008/01/21 19:06:47 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.40 2008/03/17 11:19:33 zzam Exp $
+
+*linuxtv-dvb-apps-1.1.1.20080317 (17 Mar 2008)
+
+ 17 Mar 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +linuxtv-dvb-apps-1.1.1.20080317.ebuild:
+ Added new snapshot. This mainly adds new scan files.
*linuxtv-dvb-apps-1.1.1.20080113 (21 Jan 2008)
diff --git a/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20080317.ebuild b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20080317.ebuild
new file mode 100644
index 000000000000..8228fb065eb5
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20080317.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20080317.ebuild,v 1.1 2008/03/17 11:19:33 zzam Exp $
+
+inherit eutils versionator multilib
+
+MY_P="${PN}-$(get_version_component_range 4)"
+
+IUSE="usb"
+SLOT="0"
+HOMEPAGE="http://www.linuxtv.org/"
+DESCRIPTION="small utils for DVB to scan, zap, view signal strength, ..."
+LICENSE="GPL-2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+RDEPEND="usb? ( >=dev-libs/libusb-0.1.10a )"
+DEPEND="${DEPEND}
+ media-tv/linuxtv-dvb-headers"
+
+S="${WORKDIR}/dvb-apps-3cde3460d120"
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd "${S}"
+
+ # disables compilation of ttusb_dec_reset which requires libusb
+ if ! use usb; then
+ sed -i util/Makefile \
+ -e '/ttusb_dec_reset/d' \
+ -e '/dib3000-watch/d'
+ fi
+
+ # do not compile test-progs
+ sed -i Makefile -e '/-C test/d'
+
+ # remove copy of header-files
+ rm -rf "${S}"/include
+}
+
+src_compile()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) || die "failed to compile"
+}
+
+src_install()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ insinto /usr/bin
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) prefix=/usr \
+ DESTDIR="${D}" INSTDIR="${T}" install || die "install failed"
+
+ # rename scan to dvbscan
+ mv "${D}"/usr/bin/scan "${D}"/usr/bin/dvbscan
+
+ # install zap-files
+ for dir in dvb-{s,c,t} atsc; do
+ insinto /usr/share/dvb/zap/${dir}
+ doins "${S}"/util/szap/channels-conf/${dir}/*
+ done
+
+ # install remote-key files
+ insinto /usr/share/dvb/av7110_loadkeys
+ doins "${S}"/util/av7110_loadkeys/*.rc*
+
+ # install Documentation
+ dodoc README TODO
+ newdoc util/scan/README README.dvbscan
+ newdoc util/szap/README README.zap
+ newdoc util/av7110_loadkeys/README README.av7110_loadkeys
+
+ use usb && newdoc util/ttusb_dec_reset/README README.ttusb_dec_reset
+}
+
+pkg_postinst()
+{
+ elog "Please read the documentation in /usr/share/doc/${PF}."
+ elog "The channel lists and other files are installed in"
+ elog "/usr/share/dvb"
+ elog
+ elog "The scanning utility is now installed as dvbscan."
+}