summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2004-03-26 16:43:42 +0000
committerBart Lauwers <blauwers@gentoo.org>2004-03-26 16:43:42 +0000
commitd11fc56f0994a2fe2ec0b4e4b8330eea09357885 (patch)
tree802fb01159cdd800f598e899c5181aed4b8411ee /media-tv/nvtv
parentRemoved explicit S=. (Manifest recommit) (diff)
downloadgentoo-2-d11fc56f0994a2fe2ec0b4e4b8330eea09357885.tar.gz
gentoo-2-d11fc56f0994a2fe2ec0b4e4b8330eea09357885.tar.bz2
gentoo-2-d11fc56f0994a2fe2ec0b4e4b8330eea09357885.zip
Version bump per Bug#23766
Diffstat (limited to 'media-tv/nvtv')
-rw-r--r--media-tv/nvtv/ChangeLog7
-rw-r--r--media-tv/nvtv/files/digest-nvtv-0.4.61
-rw-r--r--media-tv/nvtv/nvtv-0.4.6.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/media-tv/nvtv/ChangeLog b/media-tv/nvtv/ChangeLog
index fa4f7090e706..77faeb82f6ee 100644
--- a/media-tv/nvtv/ChangeLog
+++ b/media-tv/nvtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/nvtv
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/ChangeLog,v 1.4 2004/03/23 16:37:04 augustus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/ChangeLog,v 1.5 2004/03/26 16:43:42 blauwers Exp $
+
+*nvtv-0.4.6 (26 Mar 2004)
+
+ 26 Mar 2004; Bart Lauwers <blauwers@gentoo.org> nvtv-0.4.6.ebuild:
+ Version bump per request in Bug #23766
23 Mar 2004; <augustus@gentoo.org> nvtv-0.4.5.ebuild:
Added amd64 keyword.
diff --git a/media-tv/nvtv/files/digest-nvtv-0.4.6 b/media-tv/nvtv/files/digest-nvtv-0.4.6
new file mode 100644
index 000000000000..ab0d497d77e7
--- /dev/null
+++ b/media-tv/nvtv/files/digest-nvtv-0.4.6
@@ -0,0 +1 @@
+MD5 1ca0b59ab730e95e7dee0606efe73446 nvtv-0.4.6.tar.gz 418929
diff --git a/media-tv/nvtv/nvtv-0.4.6.ebuild b/media-tv/nvtv/nvtv-0.4.6.ebuild
new file mode 100644
index 000000000000..8826fd6179c9
--- /dev/null
+++ b/media-tv/nvtv/nvtv-0.4.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/nvtv-0.4.6.ebuild,v 1.1 2004/03/26 16:43:42 blauwers Exp $
+
+IUSE="X gtk gtk2"
+
+DESCRIPTION="TV-Out for NVidia cards"
+HOMEPAGE="http://sourceforge.net/projects/nv-tv-out/"
+SRC_URI="mirror://sourceforge/nv-tv-out/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="sys-apps/pciutils
+ gtk? (
+ gtk2? ( =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ )
+ X? ( >=x11-base/xfree-4.0 )"
+
+src_compile() {
+ local myconf
+
+ if use gtk
+ then
+ if use gtk2
+ then
+ myconf="${myconf} --with-gtk=gtk2"
+ else
+ myconf="${myconf} --with-gtk=gtk1"
+ fi
+ else
+ myconf="${myconf} --without-gtk"
+ fi
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ econf ${myconf} || die
+
+ # The CFLAGS don't seem to make it into the Makefile.
+ cd src
+ emake CXFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin src/nvtv
+ dosbin src/nvtvd
+
+ dodoc ANNOUNCE BUGS FAQ INSTALL README \
+ doc/USAGE doc/chips.txt doc/overview.txt \
+ doc/timing.txt xine/tvxine
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nvtv.start nvtv
+}