summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-05-16 06:33:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-05-16 06:33:35 +0000
commit6ee2769c9cc08a8e6f69bf652de2d6e9b9fdde26 (patch)
tree794173674eabbaf2e3c9946fe66c3c197eedb8be /media-tv
parentadded unichrome USE flag for mythtv (diff)
downloadgentoo-2-6ee2769c9cc08a8e6f69bf652de2d6e9b9fdde26.tar.gz
gentoo-2-6ee2769c9cc08a8e6f69bf652de2d6e9b9fdde26.tar.bz2
gentoo-2-6ee2769c9cc08a8e6f69bf652de2d6e9b9fdde26.zip
Fixed a bunch of bugs. Added blockers to force some upgrades. Push out the fixed init scripts on users. Getting closer to x86.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog9
-rw-r--r--media-tv/mythtv/files/digest-mythtv-0.18-r2 (renamed from media-tv/mythtv/files/digest-mythtv-0.18)0
-rw-r--r--media-tv/mythtv/mythtv-0.18-r2.ebuild142
-rw-r--r--media-tv/mythtv/mythtv-0.18.ebuild126
4 files changed, 150 insertions, 127 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 54b03c4ece15..0c980675806b 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.55 2005/05/14 17:10:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.56 2005/05/16 06:33:35 cardoe Exp $
+
+*mythtv-0.18-r2 (16 May 2005)
+
+ 16 May 2005; Doug Goldstein <cardoe@gentoo.org> +mythtv-0.18-r2.ebuild:
+ force the new init script on the masses
+ clean up some bugs... close some more bugs
+ move closer to stable x86
14 May 2005; Doug Goldstein <cardoe@gentoo.org>
files/0.18-mythbackend.conf, files/0.18-mythbackend.rc:
diff --git a/media-tv/mythtv/files/digest-mythtv-0.18 b/media-tv/mythtv/files/digest-mythtv-0.18-r2
index af9b82960007..af9b82960007 100644
--- a/media-tv/mythtv/files/digest-mythtv-0.18
+++ b/media-tv/mythtv/files/digest-mythtv-0.18-r2
diff --git a/media-tv/mythtv/mythtv-0.18-r2.ebuild b/media-tv/mythtv/mythtv-0.18-r2.ebuild
new file mode 100644
index 000000000000..0e9c24defc22
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.18-r2.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18-r2.ebuild,v 1.1 2005/05/16 06:33:35 cardoe Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="Homebrew PVR project"
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="alsa altivec arts debug dvb ieee1394 jack joystick lcd lirc mmx nvidia oggvorbis opengl oss unichrome xv"
+
+DEPEND=">=media-libs/freetype-2.0
+ >=media-sound/lame-3.93.1
+ virtual/x11
+ >=x11-libs/qt-3.1.1
+ dev-db/mysql
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ arts? ( kde-base/arts )
+ dvb? ( media-libs/libdvb )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )
+ oggvorbis? ( media-libs/libvorbis )
+ opengl? ( virtual/opengl )
+ ieee1394? ( >=sys-libs/libraw1394-1.2.0 )
+ || ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )
+ !x11-base/xfree
+ !<x11-base/xorg-x11-6.8"
+ ## THESE BLOCKERS DON'T REPOMAN RIGHT... But we have to do them cause of some users
+
+
+# ieee1394 also needs >=sys-libs/libiec61883-1.0.0
+
+RDEPEND="${DEPEND}
+ !media-tv/mythfrontend"
+
+pkg_setup() {
+
+ if ! built_with_use x11-libs/qt mysql ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs MySQL support"
+ fi
+
+ if use nvidia; then
+ echo
+ ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
+ ewarn "greater to use this. Otherwise, you'll have crashes with MythTV"
+ echo
+ fi
+
+ einfo
+ einfo "Please note, this ebuild does not use your CFLAGS and CXXFLAGS. It determines"
+ einfo "a sane set and uses those. Please do not attempt to override this behavior."
+ einfo
+}
+
+#src_unpack() {
+# unpack ${A}
+#
+# # Fix bugs 40964 and 42943.
+# filter-flags -fforce-addr -fPIC -momit-leaf-frame-pointer
+# is-flag "-fomit-frame-pointer" || append-flags "-fomit-frame-pointer"
+#}
+
+src_compile() {
+ use unichrome && use nvidia && die "You can not have USE="unichrome" and USE="nvidia" at the same time. Must disable one or the other."
+ local myconf="$(use_enable altivec)
+ $(use_enable oss audio-oss)
+ $(use_enable alsa audio-alsa)
+ $(use_enable arts audio-arts)
+ $(use_enable jack audio-jack)
+ $(use_enable lirc)
+ $(use_enable joystick joystick-menu)
+ $(use_enable unichrome xvmc-vld)
+ $(use_enable dvb)
+ $(use_enable dvb dvb-eit)
+ --dvb-path=/usr/include
+ $(use_enable opengl opengl-vsync)
+ $(use_enable oggvorbis vorbis)
+ $(use_enable nvidia xvmc)
+ $(use_enable xv)
+ --disable-directfb
+ --enable-x11
+ --enable-proc-opt"
+
+ if use mmx || use amd64; then
+ myconf="${myconf} --enable-mmx"
+ else
+ myconf="${myconf} --disable-mmx"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --compile-type=debug"
+ else
+ myconf="${myconf} --compile-type=release"
+ fi
+
+ hasq distcc ${FEATURES} || myconf="${myconf} --disable-distcc"
+ hasq ccache ${FEATURES} || myconf="${myconf} --distable-ccache"
+
+ # depends on bug # 89799
+ # $(use_enable ieee1394 firewire)
+
+ # let MythTV come up with our CFLAGS. Upstream will support this
+ CFLAGS=""
+ CXXFLAGS=""
+ econf ${myconf} || die "configure died"
+
+ qmake -o "Makefile" mythtv.pro || die "qmake failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ einstall INSTALL_ROOT="${D}" || die "install failed"
+ for doc in AUTHORS COPYING FAQ UPGRADING ChangeLog README; do
+ test -e "${doc}" && dodoc ${doc}
+ done
+
+ newbin "setup/mythtv-setup" "mythsetup"
+
+ insinto /usr/share/mythtv/database
+ doins database/*
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ newinitd ${FILESDIR}/0.18-mythbackend.rc mythbackend
+ newconfd ${FILESDIR}/0.18-mythbackend.conf mythbackend
+
+ dodoc keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+
+ keepdir /var/log/mythtv
+}
diff --git a/media-tv/mythtv/mythtv-0.18.ebuild b/media-tv/mythtv/mythtv-0.18.ebuild
deleted file mode 100644
index bb5516d0eaab..000000000000
--- a/media-tv/mythtv/mythtv-0.18.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.18.ebuild,v 1.5 2005/05/10 01:35:48 herbs Exp $
-
-inherit myth flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Homebrew PVR project"
-HOMEPAGE="http://www.mythtv.org/"
-SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="alsa altivec arts cle266 directfb dvb ieee1394 jack joystick lcd lirc nvidia oggvorbis opengl oss xv X" # mmx "
-
-DEPEND=">=media-libs/freetype-2.0
- >=media-sound/lame-3.93.1
- >=x11-libs/qt-3.1
- dev-db/mysql
- alsa? ( >=media-libs/alsa-lib-0.9 )
- >=sys-apps/sed-4
- arts? ( kde-base/arts )
- directfb? ( dev-libs/DirectFB )
- dvb? ( media-libs/libdvb )
- jack? ( media-sound/jack-audio-connection-kit )
- lcd? ( app-misc/lcdproc )
- lirc? ( app-misc/lirc )
- nvidia? ( media-video/nvidia-glx )
- oggvorbis? ( media-libs/libvorbis )
- opengl? ( virtual/opengl )
- || ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )"
-
-RDEPEND="${DEPEND}
- !media-tv/mythfrontend"
-
-PDEPEND="~x11-themes/mythtv-themes-${PV}"
-
-pkg_setup() {
-
- if ! built_with_use x11-libs/qt mysql ; then
- eerror "Qt is missing MySQL support. Please add"
- eerror "'mysql' to your USE flags, and re-emerge Qt."
- die "Qt needs MySQL support"
- fi
-
- if use nvidia; then
- echo
- ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
- ewarn "greater to use this. Otherwise, you'll have crashes with MythTV"
- echo
- fi
-
-}
-
-src_unpack() {
- # Fix bugs 40964 and 42943.
- filter-flags -fforce-addr -fPIC
-
- # fix bug 67832, 81610, etc
- is-flag "-march=pentium4" && replace-flags "-O3" "-O2"
- is-flag "-march=pentium4" && replace-flags "-0s" "-O2"
- is-flag "-march=athlon-xp" && replace-flags "-O3" "-O2"
-
- myth_src_unpack || die "unpack failed"
-
- cd ${S}
-}
-
-setup_pro() {
- return 0
-}
-
-src_compile() {
- use cle266 && use nvidia && die "You can not have USE="cle266" and USE="nvidia" at the same time. Must disable one or the other."
-
- # tested on different versions on gcc, P4, celeron & athlon-xp, and all bork on postProcess_MMX
- # with mmx enabled, so disabled for all architectures for now - FIXME
- myconf="--disable-mmx
- $(use_enable altivec)
-
- $(use_enable oss audio-oss)
- $(use_enable alsa audio-alsa)
- $(use_enable arts audio-arts)
- $(use_enable jack audio-jack)
- $(use_enable lirc)
- $(use_enable joystick joystick-menu)
-
- $(use_enable cle266 xvmc-vld)
- $(use_enable directfb)
- $(use_enable dvb)
- $(use_enable dvb dvb-eit)
- --dvb-path=/usr/include
- $(use_enable opengl opengl-vsync)
- $(use_enable oggvorbis vorbis)
- $(use_enable nvidia xvmc)
- $(use_enable xv)
- $(use_enable X x11)"
-
- # $(use_enable ieee1394 firewire)
-
- # Distcc causes some tests in the configure script to fail, bug #90185
- myconf="${myconf} --disable-distcc"
-
- myth_src_compile
-}
-
-src_install() {
- myth_src_install || die "install failed"
- newbin "setup/setup" "mythsetup"
-
- insinto /usr/share/mythtv/database
- doins database/*
-
- exeinto /usr/share/mythtv
- doexe "${FILESDIR}/mythfilldatabase.cron"
-
- exeinto /etc/init.d
- newexe "${FILESDIR}/mythbackend.rc6" mythbackend
- insinto /etc/conf.d
- newins "${FILESDIR}/mythbackend.conf" mythbackend
-
- dodoc keys.txt docs/*.{txt,pdf}
- dohtml docs/*.html
-
- keepdir /var/{log,run}/mythtv
-}